Problems with 1.2.6 on FC4

Hi Everyone - thanks for the time.

Getting this compile error:

$ ./configure --with-libmad --without-vorbis
$ make
In file included from sse_optimized.cpp:70:
/usr/lib/gcc/i386-redhat-linux/4.0.2/include/xmmintrin.h:34:3: error: #error “SSE instruction set not enabled”
sse_optimized.cpp: In member function ‘virtual double soundtouch::TDStretchSSE::calcCrossCorrStereo(const float*, const float*) const’:
sse_optimized.cpp:76: error: ‘__m128’ was not declared in this scope
sse_optimized.cpp:76: error: expected `;’ before ‘vSum’

I’ve tried export CFLAGS=“-msse” with the same results.

Thanks again.
Greg Bell
Sydney, Australia

Well, hell guys, I’m really stuck. Is FC4 too old for anybody to bother?

try configure --without-soundtouch to disable soundtouch, the library that is having the compile error. If you can get a package of soundtouch that works on FC4 then you may be able to link audacity to it using --with-soundtouch=system, provided it’s soundtouch 1.3.1 or later.