problems recording

i have moved up from a win xp pc with a creative soundblaster card to a new pc with win 10 and on board soundcard/audacity 211.
i have recorded music using audacity but there are issues:
the recording is of 2 songs at the same time instead of 1 ?
the quality of recording is poor; very tinny. comparing the original and playback its about 50% drop in quality
when i start audacity the sound level on playing audio always dips, how do i stop this?
any tips greatly received

the recording is of 2 songs at the same time instead of 1 ?

What does that mean??? Are you recording something that’s not playing???

We need some more details… Are you recording with a microphone? Something plugged into line-in? Streaming audio?

i am recording clips of music that i am already playing on the pc

no mic used, nothing plugged into line-in, audacity picks it up via the stereo mix method i think

Why would you do that?

no mic used, nothing plugged into line-in, audacity picks it up via the stereo mix method i think

Is there some effect in the player that you would like to record? Or is it to bypass DRM?

If you recorded a song, pressed Stop then recorded another song, the other song is on a second track below the first one. Audacity is a multi-track editor so plays both tracks together. If you wanted both songs in the same track:

  1. Select the second song by clicking above the Mute/Solo buttons on its Track Control Panel (where the sample rate in Hz is shown)
  2. Edit > Cut
  3. Place the cursor at the end of the first song by clicking in it then pressing K
  4. Choose Edit > Paste
  5. Click the [X] track close button top left of the Track Control Panel on the second song.

Next time you record, if you hold SHIFT and click the Record button, you can record at the end of the selected track instead of starting a new track.

You can import the files instead (File > Import > Audio… ). Then you don’t lose quality. You can drag-select exactly the piece you want to keep then Edit > Remove Special > Trim Audio. See Tutorial - Editing an Existing Audio File.

If you must record the clips, check in Device Toolbar that you are really recording from stereo mix. See Tutorial - Recording Computer Playback on Windows. As you see in that tutorial, you can choose Windows WASAPI loopback recording instead which should be higher quality than stereo mix.

If you still get fading you may have recording enhancements or sound effects enabled. See


why would i not do that? whats wrong with the post - this is a forum for help isn’t it?
no effects, just plain and simple recording clips of parts of music but the output is poor quality. that’s it.

hi thx for tips.
i only want to record one track at a time but sometimes get 2 at a time. how do i do only this?
what do i select after File > Import > Audio…?
cannot use WASAPI, i get error - check sound device. so i use MME, Stereo Mix and RealTek onboard soundcard settings

kaz and gale

the version i am using is 2.1.1
its all in the way you type it. really didnt know that full stops were that intrinsic to the query as its quicker to type it in one

Are you talking about Append-Record (SHIFT-click on the Record button)? If so, click where it says “Hz” to left of the blue waves to select only that track. Then Append Record will only record at the end of that track.

If you simply click Record you will always get a new track.

If you are taking about recording mono (one channel) or stereo (two channels), choose that in Device Toolbar.

Nothing. You can just click Play to play the track. Or drag select the part you want to play, then press play.

WASAPI loopback works for me in Windows 10.

Try restarting Audacity.

Turn off Transport > Overdub.

Set Device Toolbar to record in stereo.

If you still receive the error, set Audacity project rate (bottom left) to 44100 Hz then choose the playback device in Windows Sound, right-click over the device, choose “Properties”, click the “Advanced” tab, then set “Default Format” to 44100 Hz stereo.

You can also try Windows DirectSound host in Audacity, 44100 Hz project rate, but enable both “Exclusive Mode” boxes for the playback device (on the same page of Windows Sound as Default Format). Then it does not matter what sample rate Default Format is set to, as long as it is set to stereo.


thx Gale

its a better sound now but still needs attention. the bass is a thud echo type sound and not a clean crisp beat like the original

what settings to change for this?

Because we are suggesting you are going about this the wrong way :wink:

Recording a file is not an exact byte-for-byte copy of it. Recording it with stereo mix, so involving conversion from digital to analogue and back to digital, may lead to audible degradation.

So, File > Import > Audio… to import the file into Audacity. You get the whole audio in one track like you said you wanted. And this way, there is no quality loss at the point where you get the audio into Audacity.

Once the audio is imported, you can (for example) drag-select a part that you want to use, CTRL + B to label that region, then select and label other regions. You can then File > Export Multiple… each labelled region as a separate file. It depends what you want to do with the clips when you have them in Audacity. What is the end goal?

If you want to be sure to avoid degradation and sound effects in the audio, the answer is as above - import the audio, not record it.

If you must record the clips, exactly what choices do you have in all four boxes in Device Toolbar? -

To get a good recording of computer playback, turn off Transport > Software Playthrough in the Audacity menu bar at the top, and look for and turn off sound effects as per the link I posted before