Problems Recording Vinyl to Digital

To begin with, I am using Audacity 2.1.3. along with an Audiobox USB (which interfaces with my desktop), a TEC TC-753LC Phono Preamp with volume control, Technics Direct Drive Turntable SL-D2.

Here’s the problem: my Imac desktop died on me so, I transferred the audacity software and the previously mentioned hardware to my MacBook Pro - but, when I click on the “Monitor” Icon like I have done countless times with my desktop, nothing happens. I see the Audio level bars moving, but I no longer hear anything through the speakers of my laptop.

Now, I also transferred the Presonus Universal Control Software/App that was also formerly on my desktop - but, still no joy.

What am I missing?

2.1.3 is now a fairly old version - the latest version is 2.2.1 (and soon 2.2.2 will be released)

You can download the latest Audacity for Mac from here:


You transferred the Audacity application to the new machine but not the preferences. To hear what you’re recording, click on the Transport menu and choose Transport Options > Software Playthrough (make sure it is checked).
– Bill

I tried your suggestion but, all I get is a high-piercing screech. Not what I was hoping for. For the record, I had no problems with using the App on my desktop, just now with my laptop.

That sounds like you have the internal microphone set as your recording device and you’re getting feedback.
Remember, you lost all your settings when you moved to the laptop.
In Device Toolbar, set the recording device to your USB interface.
In Transport > Transport Options make sure Overdub is off.
Now try to start monitoring.
– Bill

Well, the feedback is gone but, I still am not hearing anything even though the sound bars are moving in tandem with the L.P. I’m trying to record. It’s very frustrating to say the least.

Gregg –

You need to get all the settings correct.
In Device Toolbar, the recording device should be the USB device and playback device should be “Built-in Output” (or similar).
To hear what your are recording, go to Transport > Transport Options > Software Playthrough and make sure it is checked.
Make sure the Playback Volume is turned up.
– Bill