Problems encountered with Audacity and Windows

I have encountered two different problems with Audacity 2.0.3…

  1. I installed Audacity 2.0.3 on a Windows 10 Laptop. I then connected a “cassette player”
    that has a USB connection (my intent is to “take off” of the Cassette" and “put it into”
    MP3 format) to the Laptop. When I tried to “play” the cassette, there was NO SOUND
    detected AT ALL by Audacity. I turned the volume all the way up on both the “cassette
    player” AND the laptop… Still no sound. However, when I connected an ear phone to the
    “cassette player” – I was able to hear sound! In addition, the “cassette player” is powered
    by the laptop via the USB connection and the “player” WAS running…
    I then installed Audacity 2.0.3 on a Windows 7 laptop – and everything worked perfectly
    I was able to “capture” the music off of the cassette tape with NO problem. Is there a DIFFERENT
    version of Audacity specifically for Windows 10 or are there some settings that have to be
    tweaked – when using Windows 10?

  2. On the Windows 7 Laptop (which worked GREAT as per above), I tried to “capture” the contents
    of a Cassette Tape of SPEECH (rather than music). When I tried it, however, I heard this awful
    screeching sound coming out of the laptop… It seems that instead of capturing the speech, all
    that was “captured” were these horrible screeching sounds?
    Can anyone explain to me what is going on – since capturing the Cassette Tape with Music
    worked PERFECTLY while capturing a Cassette Tape with SPEECH seems to just fail…

Thank you.

It should work fine with Windows 7 or Windows 10. And, most USB cassette players (and USB turntables) use the standard Microsoft-supplied drivers so compatibility is rarely a problem.

Make sure to select the USB device as your [u]Recording Device[/u]. (Do NOT select “Stereo Mix”, or “loopback”, etc.) And, select your regular soundcard as the playback device.

If you can’t hear what you’re recording, turn-on [u]Software Playthrough[/u]. (I believe it’s enabled by default). Depending on how Windows is configured, you may hear the cassette without running any applications.

Speech and music should be the same . If the sound is “messed up”, make sure [u]Windows “enhancements”[/u] are turned-off. (This shouldn’t cause screeching).

Still no success –
First - I removed the version 2.0.3 and installed the 2.2.2 on Windows 10
There was STILL no sound coming through at all (that is not only could I not hear
but the “graph” that shows the sound being “captured” was FLAT)

Then I checked Preferences:
For Devices, settings were as follows:
Host: MME
Using Portaudio V19.5.0

Playback Device: Only Choice of:
Speakers <== set to.
Microsoft Sound Mapper

Recording Device: Only Choice of:
Internal microphone <==== Originally set to this.
Microsoft Sound Mapper
Microphone Array (USB PnP Audio) <==== Reset to this.

Recording:
Playthrough – already set to
Software playthrough of input.

Still NO sound coming through being “captured” at all!
I am using a Lenovo ThinkPad T410
with Windows 10 Pro – 64 bit.

I have no clue as to what Windows “enhancements” you are referring to.

Please advise.

Here us a little bit more info:
The T410 us considered at “End of Life”. When I went to the
Lenovo Site, I could not locate any “new” [sound] Drivers. Perhaps,
that is why the T410 is not “detecting” the sound from the Cassette Player.
If that is the case, there may be no solution to this issue – unless there is
some sort of work-around.
My understanding is that Audacity does NOT always support Windows 10.
Any advice or comments?