Problems compiling 1.3.3 and CVS as of 2007-07-30

Hi guys. I’m having problems compiling Audacity on my system. It’s an Athlon64 running Slamd64 (unofficial Slackware for x86_64). gcc/g++ is 4.1.2.

This is how I configured and compiled wxGTK 2.8.4:

./configure --prefix=/usr --localstatedir=/var --sysconfdir=/etc --libdir=/usr/lib64/wxGTK --enable-optimise --enable-gui --enable-shared --enable-stl --enable-intl --enable-catch_segvs --enable-dynamicloader --enable-threads --enable-protocols --enable-http --enable-ftp --enable-fileproto --enable-sockets --enable-dataobj --enable-ipc --enable-arcstream --enable-datetime --enable-ffile --enable-file --enable-filesystem --enable-fontmap --enable-fs_archive --enable-fs_inet --enable-fs_zip --enable-geometry --enable-log --enable-longlong --enable-mimetype --enable-snglinst --enable-std_iostreams --enable-std_string --enable-stdpaths --enable-stopwatch --enable-streams --enable-tarstream --enable-textbuf --enable-textfile --enable-timer --enable-unicode --enable-sound --enable-mediactrl --enable-printfposparam --enable-zipstream --enable-url --enable-variant --enable-protocol --enable-protocol-http --enable-protocol-ftp --enable-protocol-file --enable-clipboard --enable-dnd --enable-accel --with-sdl --with-opengl

After having installed that and the other dependencies, I try to configure audacity for build with this:

./configure --prefix=/usr --localstatedir=/var --sysconfdir=/etc --libdir=/usr/lib64 --with-vorbis=system --with-portaudio=v19 --with-libmad=system --with-libsndfile=system --with-ladspa --with-nyquist=local --with-id3tag=system --with-soundtouch=local --enable-unicode --with-libsamplerate=system --with-libresample=no --with-libtwolame

When I try to compile, it gets this far and dies:

make[1]: Entering directory /usr/local/src/audacity-cvs/audacity/src' g++ -c -I../lib-src/portmixer/include -I../lib-src/portaudio-v19/include -g -O2 -I../lib-src/soundtouch/include -I../lib-src/libnyquist/nyx -I../lib-src/twolame/libtwolame -I../lib-src/allegro -I../lib-src/FileDialog -Wall -fno-strict-aliasing -I./include -I. -I/usr/lib64/wxGTK/wx/include/gtk2-unicode-release-2.8 -I/usr/include/wx-2.8 -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXGTK__ -pthread -DAUDACITY_DLL_API='' BlockFile.cpp -o BlockFile.o WaveTrack.h:232: error: type 'WaveClipList' is not derived from type 'WaveTrack' WaveTrack.h:232: error: expected ';' before '*' token WaveTrack.h:236: error: expected ;’ before ‘WaveClip’
make[1]: *** [BlockFile.o] Error 1
make[1]: Leaving directory `/usr/local/src/audacity-cvs/audacity/src’
make: *** [audacity] Error 2

Any help getting this great program built would be appreciated. Let me know if you need any further information about my system.

Check with the Linux devs to see if they can reproduce. I believe it may be you’re “higher” version of gcc. I’ll get back to ya with the results.


There’s a theory that it might be --enable-stl in your wxwidgets configuration, because we have that off in the development versions of wx (it’s a recent addition). I would also try dropping --with-libsamplerate=system --with-libresample=no from the audacity configuration stuff - it really shouldn’t matter, but it’s not routinely tested so might make a difference. If it does, then it needs fixing so get back to us.

Thanks guys, I’ll try first without the STL in wxwidgets. Will keep you guys posted.

No luck. I rebuilt wxGTK without STL, then tried the other suggestion - disable libsamplerate. Everytime it gives the same error. Maybe it is the gcc version…

It might be, but I’m running Gentoo’s 4.1.2 build without any problems here. I presume updating the CVS checkout doesn’t cure the problem?

I just updated CVS, and no, no change. I also trying building on another machine running Slamd64 11.0, which has gcc 3.4.6 on it. I got the same exact result. It’s got to be one of the following:

  1. An error in the configuration that I gave to build wxGTK
  2. An error in the configuration that I gave to build audacity
  3. A genuine bug that seems to have only appeared on Slamd64 (least likely of the possibilities I think)