Problem with slight latency when making addt'l trac (Solved)

Hi everyone,
I’m really loving Audacity on my UbuntuStudio 12.04. I had to remove Pulseaudio in order to avoid conflicts between it and ALSA/Jack, and now things seem to work well.

I play an external keyboard which is hooked up through the mic in jack to the PC, allowing me to record in realtime. No dropouts, glitches, anything. Great!

My problem though, is that after I make a track, and proceed to record a second track, in which I can hear the first track and play along with it, when I play the two tracks afterward, the second track is slightly off: sometimes a fraction of a second before the first track, sometimes a hair late.

Is there anyway to prevent this, so that I don’t have to trim the second track to make it match up with the first?

Thanks in advance to everyone,

That’s Recording Latency and it’s easily adjustable in Audacity Preferences – assuming it doesn’t move. If it changes with each show, that’s much more serious. Now you’re into problems with drive track management and computer internal timing and delays.

I couldn’t help noticing you were happy about solving problems with dropouts, glitches, etc. Do you have a computer right on the edge of not being powerful enough to produce live audio? That kind of thing can cause your delay problem, too.


Hi Koz,
I’ll try adjusting the preferences and see what happens… FWIW, I noticed that the second track, selected as “new stereo track” was a hair ahead. The third track, which wasn’t selected as a stereo track but by just pressing record, was a hair behind.

I’ve read on the Audacity tips about using the time shift tool, and also about enabling DMA. Would either of these be useful?

The dropouts/glitches were noticed when I was using UbuntuStudio 11.10. I’m sure that my built-in audio card isn’t the best in the world; but it seems to do the job for me, and moreso with this upgrade. At least for now! :slight_smile: 3GB of RAM, and I don’t have other apps open while I record. In fact, the only open is Audacity. (Maybe using the “renice” command would improve things even more?)

Much thanks for your time,

I’m on a Mac, so I’m only going to be able to address the areas common to both platforms.

If you consistently record the same method, overlaying track two, track three, track four and they all match each other but miss the first track, that’s plain vanilla Recording Latency and you can adjust that to zero. I published one method and Steve published another one. They both work by sending track one immediately back into the computer as track two. Carefully measure the difference and use that as the correction value in Preferences.

Again the voice of doom, if you do this four track test thing and the tracks all wander with respect to each other, we can’t help you.


From what I can see, when I create a new stereo track and record on it, when I play it back, it is ahead of the prior tracks. Wouldn’t this be a type of “negative latency?”

Also, I’m wondering if I used my external synth to control a virtual synth, if I would get different results. As it stands, all signals (sound and play data) are sent through audio in, and therefore through the audio card. BUT, if I used midi through USB, the audio card would “work less” since the audio would be reproduced based on the virtual synth rather than the signals coming in through the audio in jack.

Just a thought…
I guess messing with things a bit should clarify things.


Hi everyone!

I solved it! Yeah!) I looked at the latency correction, and saw that it was set at -130 milliseconds! I changed it until the best setting was 0. Now I don’t have the latency problem anymore!

However, I did find a bug: when exiting the preferences window, the main window’s labels at the top (edit, view, transport, tracks, generate, etc.) all disappeared! Only a part of the file button was left (fortunately) to click on, to open a new project.

Thank you for your time, Koz. I think I’ve got things just where I need them… without having to buy a new audio card! (I was starting to think that was the problem…)

Kudos to everyone at Audacity!


Thanks for letting us know however please see for the workaround and solution for this wxGTK problem.


Got it! :wink: Thanks!

Oh, one last thing: I think it would be really neat to be able to have playthrough applicable not only when recording, but also during playback. When I add tracks, I like to play new lines on top of them without actually having to record in order to hear it. Maybe on the next version?..

Thanks again.

As you’re using Jack you can use the “Connect” screen in QjackCtl to connect the System output to the System input (be careful not to create feedback loops outside of the computer). This will give you extremely efficient software playthrough whether Audacity is running/playing/recording or not. You may need to turn off “Software Playthrough” in Audacity to avoid multiple playthrough loops.

Hi Steve,
thanks for the suggestion. I’ll try it and see what happens. If playthrough is allowed during playback, then I can play along with anything I dump into Audacity! :slight_smile: Sounds fun!

One last thing: I see that when I open a new track, it acually makes two new tracks. I also see this “ghost” track when I open the mixer. What is the purpose of this track?

Much thanks.

I don’t know what you mean. Could you post some screenshots to illustrate.

I just read this now. Tonight I’ll do a screenshot.


Here it is. The “added” track is the second (middle) one. No data on it, of course.


That’s weird. It looks like a label track has been added but with the name “audio track”.

Could you give me exact steps to reproduce this weirdness.
Also, which version of Audacity (look in “Help > About Audacity” for the exact version number).
Where did you get Audacity / how did you install it?

Well, nothing special. I just open the app, activate the monitoring to control sound, then hit record and do a first track.
Then I select ctl-shift-n to make a new track, and record it. Afterwards, I find that there is a “middle” track inserted.

I’m not at that PC at the moment (I’m at work), but it’s the “default” Audacity that gets installed in the package when installing Ubuntu Studio 12.04. (I think it’s the newest version.)

Let me know if you want more info.


Ah, I see what’s happening.

Your steps do not quite work, Ctrl+shift+n does not work until after you stop the recording, but I get the idea.

The middle track looks a bit strange just because it is quite small vertically (so the controls and track info are hidden), but otherwise it is a normal audio track.

You don’t need to press Ctrl+shift+N.
A new track will be created automatically each time you start recording.
If you need to continue recording on the same track after pressing stop, use Shift+R or Shift+Record button, or select “Append Record” from the Transport menu.

Oh, ok. I thought I needed to select a new track. But it’s better as you say-- one less step in the recording.

I’m about to start a new thread, where I’m setting up Audacity on AntiX, which doesn’t have a realtime kernel, and I need some advice.