Problem with second track

Dear all,

When I record a single track everything is fine. Then when I use the overdub function to record a second track the sound is all choppy, stuttery and sometimes I get noises. The stuttering also appears on the wave, i.e. there will be parts of the track with only a flat line. I have a relatively new computer with 4 Gb RAM which is usually rather stable, I can hardly imagine it being a processor overload or something. I have tried recording only mono though with the 16 bit quality, but that didn’t help. As the first recording is fine, I think mic problems can be ruled out as well. I have tried all the troubleshooting options that I understood to no avail (you probably know by now I am a nitwit). What can I do?

Kind regards and thanks for responding,
Audac

Try increasing your latency (buffer size). (Edit → Preferences → Latency)

And, make sure no unecessary applications are running, and try turning-off any “background” operations, such as anti-virus.

I have a relatively new computer with 4 Gb RAM which is usually rather stable, I can hardly imagine it being a processor overload or something.

It’s related to CPU usage, but it also involves the length of time that some operation is “hogging” the CPU. If some driver, application, or background operation runs for a few milliseconds too long, the recording buffer can overflow before the operating system gets back-around to reading it. (During playback, the danger is buffer underflow.)

That “Audio to buffer” setting is in the “Recording” section of Preferences.

You may have to experiment as there could be multiple contributory causes of the problem. There is a fairly full list here: Missing features - Audacity Support .


Gale

Thank you for your helpful comments. I have tried installing the enditall to close all programs, shut off my firewall, run the latency check (which reported it should be fine), increased the buffer to 300, prioritised audacity for the CPU, disabled all the meters in the screen and minimised it (so more or less everything recommended in the link), and it has not helped a single bit… I have run this program earlier on a much older computer (two different ones, actually) and have never experienced any problems. What else can I try? Any ideas?

You’ll need to give more details, then.

See the pink panel at the top of the page. Version of Audacity? Version of Windows, and 32-bit or 64-bit?

Make and model number of the computer?

What recording device have you chosen in Device Toolbar ? Are you using the same device for playback?

What you are looking at now is that you may not have the correct drivers for whatever sound device you are using, which may be making it incapable of recording and playing back simultaneously. Or you may have different sample rates set somewhere and the extra work to do live resampling is causing the dropouts (this is most likely to be an issue with an external sound card). See: http://manual.audacityteam.org/o/man/faq_recording_troubleshooting.html#sync .


Gale

Audacity 2.0.5, used the .exe installer
Windows 7 Ultimate sp 1 64-bit

Computer is a Lenovo T410 Intel i5 CPU 2.53 GHz
4 GB RAM, of which 3.8 GB is available
250 GB empty space on local disk

Recording device is the internal mic (conexant 20585 SmartAudio HD)
Speakers are conexant 20585 sm

I use the same device for playback, I have checked the sample rates and tried the windows directsound option.

I checked for driver updates through configurations but presumably there were no updates.

Anyone have one last shot? If there’s no obvious solution, I think I’ll stop using more of your and my own time on this and try find an alternative.

If you are serious about making overdubs might it not be an idea at the least to use an external mic, even if a cheap dynamic one?

OK, I suggest you uninstall the Conexant device in Device Manager.

Install the Conexant Audio Software from this page: Conexant Audio Software for Windows 7 (32-bit, 64-bit), Vista (32-bit, 64-bit), XP (32-bit, 64-bit) - ThinkPad T410, T410i, T410s, T410si, T510, T510i, W510, W701, W701ds, X201, X201i, X201s, X201 Tablet - Lenovo Support NL .

Then reboot.

OK. If you choose Windows DirectSound, make sure both “Exclusive Mode” boxes are checked for all the individual recording and playback devices.

The other solution would probably be to buy a USB interface and an external mic with amplifier or phantom power, or a USB mic with a headphones output.


Gale

I’m afraid that didn’t work either. If a mic would help I might consider buying one, I think for now I’ll look around for alternative software and see if I walk into the same problems.

Anyway: thanks a lot for trying to help me out, I really find it awesome you spend time helping a complete stranger.

I seem unable to edit my post, but I wanted to add that I did indeed have the same problem using a different program. So I guess it comes down to an external mic then and see if I can make audacity work.

OK but I take it you understand that an external mic with 1/8 inch connector for the mic port of the built in sound card is unlikely to help you, because the assumption is that the sound card is the problem.


Gale

To be honest, I did not get that so many thanks for the add. Is my sound card broken or just not suitable for this purpose? The computer is relatively new, so if it’s broken I’ll take it back to the store.

Motherboard sound cards cost a few dollars to produce. You may just be unlucky with it, and if they replaced the motherboard you “might” be able to make overdubs without glitches.

I suggested:

a USB interface and an external mic with amplifier or phantom power, or a USB mic with a headphones output.

The “external mic with amplifier or phantom power” would be a quality mic and in most cases require a USB interface to connect it to that had an XLR input .

Have you tried complaining to Lenovo? Sometimes computer manufacturers are prepared to fund a USB interface or USB sound card rather than have the computer returned.

If your only concern is the glitches and you don’t need to monitor yourself then a basic USB sound card with a standard 1/4 inch mic input may be good enough for you. That would be very unlikely to glitch on overdubs unless the basic problem is with the disk I/O on the computer (which I doubt).


Gale