Problem With Recording Echo

I’ve been trying to record from a music file in audacity and everytime I record I hear the echo of what I just said in my earphone. By the way, I am recording from a logitech headset. I really want to know how to get rid of it because it throws me off and makes me record slower than what I should be.

Preferences > Audi I/O > Playthrough

Juggle with those settings until you find one you like. Hardware Playthrough should give you the least delay, but not all system support it. Do you get your voice twice, or once late? When you strike you microphone once with a pencil, do you get two clicks?

This post should totally be in one of the machine forums. Which kind of computer do you have?


Actually I went to another website where this user had the exact same problem and that is the same thing another told them to do.


And that web site would be…?