Problem with recording at 2X speed

Hello All,

I found a couple similar threads but my situation seems a bit different. I’m copying a bunch of old LPs and have run into a snag with either the recording or playback speed. The first ten albums recorded great (aside from some pops and scratches). I’m running an old Technics turntable into a new Onkyo TX-8160 receiver in the phono input. The line out goes to a Scarlett 2i2 interface which is set for 44100 hz at 16 bit. Audacity came with that device. I could take that to 96k but still at 16 bit.

This afternoon I tried to record a Mozart album from the early 1980’s that has better than 30 minutes of music crammed on one side. Playing it and listening to it on the monitor-out of the interface it sounds just like it should – but the playback both on Audacity and Foobar is much faster. The playback settings on the PC are 24 bit, 44100 Hz. I only have 24 bit choices on the Windows audio. IIRC, the Scarlett didn’t have proprietary drivers.

If the first albums had crashed I’d have been here sooner but I don’t think I did anything differently for this one. If anyone has some ideas on what I need to do, I’d love to hear them. Also let me know if I should put up some screenshots.

Thanks, Skip

PS: Win 10, i5 computer, 8G RAM, SSD and HDD, fresh Audacity downloaded last week.

Is it playing at normal pitch or much higher than normal pitch?

If it is at normal pitch, then the problem is due to ‘skipping’ (bits of audio missing, so that the remaining audio is shorter). The first thing to try in this case is a reboot. If that doesn’t help, there’s a big list of things here:

If it plays higher pitched, then it is a sample rate problem, in which case setting everything (sound card and Windows and Audacity) to 44100 Hz sample rate may fix the problem.

Thanks Steve, It is playing at a high, quick pitch – like fast forward. I can’t be sure from the sound if it is double speed but the length of the recording (give and take some slop from editing) is almost exactly half the printed duration of the content. BTW, I tried recording another LP and it did the same thing so I must have inadvertently changed the settings.

I don’t think this would have anything to do with it but thought I should mention the setup: I’m using a USB DAC between the PC and the receiver that is capable of higher hertz. It sets itself automatically to the source material. It isn’t in the signal chain for recording though. I can’t listen to the headphone out while recording. The Scarlett has its own headphone out and I have to set the receiver for “phono” for incoming LPs.

Cheers, sh

PS I’ve attached the properties detail on a) one of the 2x speed songs and b) a good one in case there is something in the code that helps.
Way too Fast.rtf (1.5 KB)

I hate this type of problem because it’s usually just one small detail somewhere in the chain causing the problem, and the challenge is to find it.

Let’s start off with a description of the equipment set-up, if possible with model number, to describe exactly what is connected to what and how. You’ve given most of this, but let’s get the full “signal chain” from start to end all in one place, for example:

  • Technics R24A turntable RCA out connected to “phono” inputs of a Rogers B431 phono pre-amp.
  • RCA output from Rogers B431 pre-amp to “line” inputs of Scarlett 2i2
  • Sennheiser HD800S headphones plugged into Scarlett 2i2 headphone out

Also the settings in:
“Edit menu > Preferences > Devices”
“Edit menu > Preferences > Quality”

and for the recording device (the Scarlett 2i2), the settings in the recording tab of the Windows Sound Control Panel.

I’m sure it is one box I did/didn’t check.

Incoming: Technics (circa 1983) turntable with an AT 1200EX cartridge.
RCA outs to the Phono input on an Onkyo TX-8160 stereo receiver
RCA line-out of receiver to 1/4" mono on both channels of the Scarlett 2i2
USB 2.0 out to motherboard.

Scarlett settings:
Recording: Focusrite Audio – not onboard chip settings
2 channel, 16 bit, 44100 Hz (all choices 16-bit)
pass-through line out (not used) and headphone out with independent vol pot
headphones: Philips SHP9500

Playback Device on Audacity:
Speakers SMSL M3 DAC (automatically conforms to input signal, at 44.1k but can go up to 192)

Of note: I’m not using the onboard Realtek drivers for playback. I am using them for input although I hope the A/D interface is feeding digital into the PC. What’s so weird is that the records I did Saturday and yesterday morning sound great. I have to clean-up some cracks and pops but it’s definitely music.

I can (and probably will try to) bypass the receiver and go directly into the Scarlett from the turntable. I’m using the receiver as my phono preamp so I can hear it on the speakers but I have an auxiliary preamp I can add if the signal is weak. The Scarlett can accept line or instrument signal levels so between them, getting the meters right shouldn’t be hard.

Audacity looked quite normal except for the time-line. I got the levels just right. The Scarlett and Audacity input levels track pretty closely. I have them set so transients barely reach the red. While recording, the DAC, receiver and Scarlett headphone outs sounded great as did the speakers driven by the Onkyo. So I know noise getting in is what I want to record.

Recording a long Mozart piece twice was as much classical as I could stand in a day so I reloaded the Audacity drivers, put on Ziggy Stardust and got the same result.

I’m not married to any of it. If I should completely purge the old programs and reload it, that’s no problem. Sometimes a fresh start is better than figuring out what went wrong.

Thanks again for your help, sh

I don’t understand what you mean “Scarlett settings”. Where are these settings?

Is your computer a laptop?

I don’t know what you mean by “reloaded the Audacity drivers”. Do you mean you reinstalled Audacity? That only resets Audacity settings if you enable the “Reset Preferences” box half way through installation.

So are these settings in Windows Sound, Recording tab? Are the Exclusive Mode boxes there checked or unchecked?

Is your project rate bottom left of Audacity 44100 Hz (which is the Audacity default)? What host are you choosing in Audacity’s Device Toolbar?

You aren’t if you are recording from the USB cable.

Do you have first or second generation 2i2? It makes a difference as to which driver you use, but my understanding is that you should follow the instructions in the manual that came with 2i2 to install Scarlett’s own drivers. Using Windows generic USB Audio drivers could easily cause a speed problem even if all settings are matched to the same sample rate.


Were you able to determine if it’s got skips/missing bits or if it’s just fast? If you can’t tell, there is a playback speed control in Audacity so you can slow it down to normal speed.

As Steve suggested, if something else is running on the computer that’s interrupting* the recording, you’ll be missing bits and it could play back faster with those little missing sections.

If it’s just playing too fast without any skips, that’s probably a driver problem.

…Let’s solve the real problems first, but…

I can (and probably will try to) bypass the receiver and go directly into the Scarlett from the turntable.

No. You need the RIAA equalized & impedance matched phono preamp. A mic preamp won’t work correctly.

I got the levels just right. The Scarlett and Audacity input levels track pretty closely. I have them set so transients barely reach the red.

Stay completely out of the red! Unlike analog tape, digital is unforgiving and will hard-clip if you try to go over 0dB. And unlike analog tape, there is no tape hiss so you don’t need a hot signal to overcome the tape noise. It’s OK to hit -3 or -6dB on the peaks, as you can always amplify digitally later.


  • Technically, interrupts are normal with a multitasking operating system. There are input & output buffers and if the operating system doesn’t get back-around to reading the input/recording buffer in time, you get buffer overflow and a glitch.

I’ll do my best. I reloaded the Audacity program but did not delete it first.

Here are the recording settings for the Scarlett:
Scarlett settings.png
It runs into a USB 2.0 port so these settings don’t appear to affect the native motherboard sound drivers. The same goes for the DAC coming out of the computer. For this project, I am not using the Scarlett as the playback device since the PC through the receiver does a good job. This cut off the Exclusive Mode but both boxes are checked.

The recording is just fast. There are no skips or pauses. Except that it only takes 31 minutes of space for 62 minutes of music, you can’t tell the difference in the waveform.

I flirt with the red but that’s it. Plus, I haven’t recorded symphonic music before. When they bring up the horns, I’m not experience enough to anticipate them. The solution is to eq down and do it again. Not a deal killer.

My computer is a desktop. It’s a hot-rodded Dell with a new power supply, SSD and HDD, lots of RAM and a dedicated graphics card. I added a couple extra fans too.

So I’m stumped. One album records perfectly. The next sounds like the Chipmunks. I didn’t change anything that I know of on any of the settings.


Please can you confirm, if you connect your headphones to your Scarlett’s headphone output, turn on direct monitor and mute any sounds from software, is the playback speed still fast?

Doing this bypasses any software problems and routes the inputs directly to the headphones output.

If the problem is still there then I’d suggest the issue is earlier in the chain, at the record player.

Please can you check what speed the record needs to be at (probably 33 1/3 RPM) and set your turntable to match this.

As the sound is speeded up, it sounds as though you may be using a faster speed, 45RPM or higher, when the album needs to be at a lower speed.



Check the turntable speed as Focusrite suggested.

Set your Audacity project rate bottom left to 44100 Hz If the Scarlett is set to a 44100 Hz 16-bit choice.

Please look at these questions:

If you have lost the manual or any drivers CD you had, you can obtain them from Focusrite:


Something else you can try - Try all 3 [u]Audio Host[/u] options. (Maybe one of them is having driver compatibility problems.)

And if that doesn’t help… Does it play back too fast in Audacity immediately after recording, before exporting? I would assume so… I wouldn’t expect anything to go wrong during export, but this is an unusual problem and something unusual is going on…

…Its also possible that the Scarlett is flaky. If you have a desktop computer with a regular soundcard, try the line inputs. If you’ve got a laptop, try the built-in mic. (If those work OK, it won’t tell you if it’s hardware or drivers but it will confirm that it’s a Scarlett related issue.)

I solved the issue but can’t explain how. The Scarlett was set for 16-bit 44100 hertz and Audacity was set for 24-bit 44100 Hz. I put them both at 96k and it worked fine. I lowered the Audacity back to 44100 and it worked fine. Then I lowered them both back to 44100 and it works fine. No clue what happened but as a slap upside the head, it worked. Not an elegant solution but I’ll take it. Thanks to all for your input. sh

I’m glad you solved it, but it still seems like you are saying that the Scarlett is unpredictable. If it happens again, come back to this topic and look at all the suggestions made here, including drivers and Audacity Audio Host.

Remember to cold boot regularly. Windows button, Power button then hold SHIFT on your keyboard and click “Shut Down”. Not doing this can cause just about any kind of problem with a USB device.


I think it comes down to confirming the speed every time you load the program. The speed shows the same but maybe it doesn’t really believe it until you pat it on the head. Thanks for you help, sh

As I said, there should not be that kind of variability. We have outlined the steps you can take which are founded on much experience helping users with similar problems.


Not Audacity – the driver for the Scarlett.