Problem with overdub...

hi guys…im a noob whos finding his way around Audacity…

my problem involves the overdub feature…i can record the first track fine(guitar) but when i try to overdub a second guitar or vocals it sounds really bad…like half the original track is there mixed with some of the new recording and its garbled together and sounds like its under water (sorry i dont know to many tech terms)…

while im recording the second track its not “spill” from the speakers as i use headphones to monitor for the overdub its just that i cant figure out why the first recording works fine but the second track is not…i have clicked the “overdub:play other tracks while recording or monitoring” button so im all out of ideas…

Ive also had the same trouble recording guitar over drum loops?? the drums play perfectly but as soon as i record the guitar it sounds really bad,as if the drums are recorded over the guitar in the second track??..any help in this matter would be a great…

thanking you all in advance…

We need to know: Audacity version; computer; operating system; sound card settings. Then we can start to diagnose your problem.

– Bill

sorry Bill…my version is the new 1.3.9…computer is a brand new compaq presario cq60-420us notebook laptop with pentium processor and running on vista,the sound card is the bog standard one that came installed when i bought the laptop…i hope this helps and sorry again for not listing that at the start…

many thanks…

Thanks. I’ll now leave this to the Windows elves.

– Bill

ok this is really doing my head in… i can record perfectly for one track ie the guide track of guitar and vocals in one track so that leads me to believe everything is set up the right way for the mic etc.i have tried recording without the overdub button pressed and this also works but as i cant hear the guide track its of little help…the problem is after i record the guide track i cant then overdub another lead guitar track…all i get is a garbled mix of the new guitar line mixed with the original and alot of strange sounds?? i dont have the old track highlighted so i cant for the life of me figure out why only on overdub recording that it goes south?? is it just the overdub is set up wrong?? i cant record any overdubs while monitoring through headphones without this problem kicking me square in the nuts each time…

any ideas guys??

In Audacity
Edit menu > Preferences > Recording Tab
Check that…

“Overdub” IS selected
“Software Playthrough” IS NOT selected.

Close Audacity Preferences.

That’s the Audacity side done, now it’s all down to your sound card.

You probably have a RealTek HD, or a Sigma Tel sound card with a horrible user interface that hides half of the many dozens of settings.
With Vista - that makes it even more horrible for setting up - these things are designed for playing YouTube and DVDs rather than recording, so you will probably have to hunt around to find the settings. Also, the sound card interfaces vary from one machine to another - I think the designers change the layout every Wednesday, and again on Friday if they get bored.

There’s 2 places to look;

  1. The Windows Control Panel
  2. The sound cards “Mixer Panel” - you will probably find this as a loudspeaker icon in the bottom right corner of your Desktop near the “Time / Date”.

This is a laptop, so you probably do not have a “Line-In”, and are probably recording through the “Mic-in”. However, I suspect that your sound system is set up to record from “Stereo Mix”.

Check in the Windows Control Panel first (see here: ).

Then go to the Sound Card Mixer Panel and look for the Recording settings.

You are looking to set it to record from Mic-in (or possibly Line-in, if available and if you are using a high level signal). You do NOT want Stereo Mix.

If at a later date you want to record from, say, YouTube, then that is when you need to record from “Stereo Mix”.

many thanks for the info Steve…and yes as its a laptop i dont have a line in only a mic in…it doesnt give me the options i need in vista to adjust any input sources so im up the creek without a paddle(in my options it only has mic and nothing else)…it was so much easier using XP instead of vista with Audacity but so be it…i think ill have to bite the bullet and buy a USB interface recorder and use cubase instead…its such a shame to buy a new laptop and then discover the internal soundcard is not worth a dime…i cant even lay overdubs as it is…we live and learn…

thanks again for the help…time to look at USB recorders…sigh

No need to abandon Audacity for CuBase. Once you have your USB interface it should work with Audacity.

– Bill

I bought a laptop PC knowing that the sound card would probably be rubbish, and I wasn’t disappointed. I usually record from a little mixing desk, so I need a decent Line-in and Line-out. Less than $30 got me a Behringer UCA-202 and it works great with Audacity.

I have a Thinkpad T410 running Ubuntu Lucid, which has the 1.3.12-2 beta of Audacity.
So I can record my first track AOK. and it sounds fine - my input and output device is the MAudio Fast Track USB.
But I’m having the same problem as described in this thread.
When I go to overdub, I get a visual cue of a track with lots of spaces in it and then playback sounds like someone’s gone in and chopped out parts of the vocals.
I have Overdub checked and Software Playthrough NOT checked. I do NOT have the Sound Activated Recording checkbox checked.
I have the Interface Host set to ALSA (PortAudio V19 devel).
I’ve tried killing pulse (and setting autospawn to no to prevent it from starting again) too, and I have the same result.
I’m going to attach a little ogg file - you can hear the guitar (track 1) sounds great, but track 2 sounds pretty awful.

Actually it looks like export selection only exported track 2 there, but that is the one with the “issue” so that should suffice :wink:

Yes indeed it does suffice. You have a bad case of “drop-outs” (skips). I don’t know why you are getting it as bad as that with only two tracks. I would have expected that you would be able to run at least a dozen tracks before anything like that. There are some general tips about skips here: that you can try, but it seems that something in your system is just not happy.

Why are you killing PulseAudio? Current versions of Audacity should be able to run very well with PulseAudio running.
I have “Edit menu > Preferences > devices” set to “ALSA”, “default”, “default” “2 (stereo)”
“Edit menu > Preferences > Quality” set to “44100/32 bit/fastest sinc/none/Best sinc/shaped”.

I’m currently running Karmic, but I’ve used the same settings on Lucid.

I use the “PulseAudio Applet” (Pulse Audio Device Chooser) for setting the input and playback settings.

If none of this works for you, would you consider using Jack audio system? Ideally Jack should run on a Real Time Kernel (as in Ubuntu Studio) but I’ve had Audacity 1.3.12 run well with Jack on a stock Ubuntu installation.

I run jack in non-realtime mode (I built a RT kernel, but then I had problems building the graphics nvidia driver against it, so I had to go back to the stock non-RT kernel). At the beginning I used to have some occasional xruns which would come noticeable as glitches on listening. I solved my problem by running jackd with the ‘-s’ option (from the manpage: --softmode Ignore xruns reported by the ALSA driver. This makes JACK less likely to disconnect unresponsive ports when running without --realtime). I think the occasional xruns still occur but there’s no more noticeable glitches in the hearing.