Problem with opening sound device?

I just recently installed Audacity 2.x on windows 7 starter. I was using Audacity 1.3 beta until the sound device i was using became unresponsive. An m audio fast track. Every time I used it as the default playback or recording device via fast track an error pop up stating to check the project rate and I/O settings. In preferences there’s no audio I/O tab on the left hand side? My voice still picks up in my headphones when I set it but there was always an issue opening the sound device. When I went into the start tab on the desktop into the hardware and sound tab I discovered that everything was enabled so I’m confused on where to go next.

Audacity looks for sound devices when it starts. If you have a ratty USB connection, Audacity will forget about the device at each data interruption. If you want to try and chase it, Transport > Rescan…


It’s odd, because its not the sound device, I’ve tried the mbox on a different laptop and it worked fine. however, I scanned the audio devices and it still pops up with the error message. very strange.

Audacity > Edit > Preferences > Devices > Recording. Is your device listed there? Stereo?

Audacity > Edit > Preferences > Quality > Sampling: 44100, 16-bit.

Those are generic settings that almost everybody supports whether they can go higher or not.


Which MBox? Exactly.

Everything is listed correctly in the devices preference. not listed in recording however. the sampling rate is fine. Its actually not an mbox but an m audio fast track.

Have you tried rebooting the computer?
Try both the “MME” and the “Direct Sound” options in the device toolbar.
Ensure that the “Sample Rate” matches in both “Edit > Preferences > Devices” and Windows Sound Control Panel. Try both 44100 and 48000.
Ensure that mono (1 channel) / stereo (2 channels) match in both “Edit > Preferences > Devices” and Windows Sound Control Panel.

Yeah, ive tried both of those solutions and idk. no love still. any other suggestions?

Have you been here to get the latest Windows 7 drivers for your Fast Track (click the “USB Interfaces” button). Choose the link for the exact version of Fast Track that you have.