problem with lp transfer [SOLVED]

i have safari 10.10.5. i have, i believe, downloaded the latest audacity. my goal is transferring lps to digital to itunes. when i open audacity, open a new file and try to begin a track, i get feedback on the volume, and no audio when i try to preview the track before recording. i am using the music hall usb-1 turntable. i had been successfully transferring lps, but recently took my computer in to have a problem fixed, and this problem has arisen since i reconnected the turntable, and downloaded the latest version of audacity. i deleted the previous versions i had. i overrode the security block that safari has. would like to know what i am doing wrong and/or not doing.

In Device Toolbar choose the USB turntable for recording device and the built-in audio for playback device.

If you do not see the USB turntable recording device, click Transport > Rescan Audio Devices.

Then to hear the input without recording you have to turn on Transport > Software Playthrough, and click in the recording meter (so it does not say “Click to start monitoring”).

We appreciate if you tell us all three numbers of the Audacity version, because some sites do not always have the latest version. See the pink panel at the top of the page.


thank you. i have been unable to try you suggestions/directions yet. the three numbers are 2.1.2. here’s to the problem being solved. enjoy marvin

gale-followed your instructions, and have met with success. many, and profuse, thanks. will keep the instructions, hopefully unnecessarily, for future reference. enjoy marvin