Problem with INPUT Window7/ audacity

Ok I have an Edirol Audio Capture the “supposedly” converts my ext. Dynamic Mic to USB… Plugged in the AC and windows found the drivers… Box lights up… BUT Impossible to get my PC via AUDACITY to recognize it as a sound INPUT… It shows up on the PC: Printers/Other/ but on Audacity INPUT I’ve only got Internal Mic/ USB Webcam mic and Microsoft Mapper . Strangely enough the Audio Capture shows up on the Output;
( Speakers) BUT impossible to get the Mic working … ? I’ve checked and rechecked Windows 7 says the drivers are up to date…
Am I missing something here…like a little ticked box that will make it all work. Matos: Lenovo T410 running Windows 7 pro and the Audio Capture is EDIROL UA-20 + a normal Dynamic hand held microphone.

To avoid confusion, please don’t use abbreviations like AC (does that mean “alternating current” or “Audio Capture”?) or “Matos” (I have no idea what that is). Thanks for the details otherwise, but what version of Audacity and what is the exact model number of the Edirol - FA66, UA something?

You need to be able to see Edirol on the “Recording” tab of Windows “Sound” - see Missing features - Audacity Support. Make sure the Edirol is enabled there by right-clicking over it .

See also the green box “Detecting USB and Firewire Devices” here: Audacity Manual.

When Windows sees the Edirol in “Recording” then do Transport > Rescan Audio Devices in Audacity.

If you are only connecting a mic to Edirol, try setting Audacity to mono recording in Device Toolbar. If the waveform won’t go above half height, record in stereo and close the empty track.


Right… My Adacity is 2.1.0…the EXACT name of the EDIROL… Is EDIROL Audio Capture UA- 20// 24 bit Digital USB Audio/Midi interface .
In the little window to the left of the Mic setting I have NME Windows WASAF and Windows Direct sound.
If I use WASAF I can select the Mic Setting: Record Device/ SPEAKER Edirol/ loop back… BUT Still get no sound from the Microphone.
If I use NME or Windows Direct sound… I get I can use the INT Mic or the USB webcam Mic… BUT no sign of the Edirol/// both Int. Mic and the USB webcam Mic work on Audacity Monitoring/ record and Playback… but I can only hear my voice through the int speakers ONCE its been recorded.
I find it strange that the only Edirol Mic INPUT is marked “Speakers” ???*

Ok I solved that problem… went to windows 7 “sound box” right clicked and found and enabled the Edirol… Now the mic works.
Next problem is that I have a Lenovo T410… so NO “stereo Mix” in the sound recording box… so no Stereo Mix on the Input Audacity box… so no f***** way to record backing tracks from the net. I get the impression that windows 7 and Lenovo dont want me to record stuff… Think I’ll buy a MAC
Of course I could physically hard wire the Lenovo headphone out to the Edirol input to record the backing track… but I suppose the sound quality will be rubbish… Any other idea’s

Make sure those are not typos or you may have a spoof version of Audacity. Those should say “MME” and “Windows WASAPI” (you may only see “Windows WASAP” before you expand Device Toolbar though).

The “loopback” input is for only for recording sounds playing on a device.

As I suggested you should do. :wink:

When you were in the Recording tab of Windows Sound, did you right-click in empty space and choose “Show Disabled Devices”? Sometimes stereo mix can be made to appear that way, then you just have to right-click over it and enable it.

If there is still no stereo mix, go here Page Not Found - Lenovo Support US and install or reinstall the latest correct audio drivers for your machine. Sometimes having the correct drivers can enable stereo mix.

Obviously there is a concern about piracy. And Mac’s as shipped do not let you record computer playback at all without using a cable - it cannot be done.

Please read Tutorial - Recording Computer Playback on Windows - Audacity Manual. As you can see there, even if you don’t have stereo mix, you can choose “Speakers (loopback)” of the built-in audio in Device Toolbar to record audio playing on the Lenovo. Play the stream before you press Record.