Problem with G-Track Microphone !

I’ve noticed that when I’ve been recording out of my microphone (Samson G-track) that the audio is only coming through one speaker, the beat is coming through both but the voice is only working through one side, I’m not sure on how to fix this, can anyone please help?

The microphone is a mono device, so you should set Audacity to record “1 channel (mono)” when recording from the microphone.
“Edit menu > Preferences > Devices”.
The recorded mono track will play through both speakers.

For any tracks that you have already recorded, assuming that you are using Audacity 1.3.13, click on the track name, then select “Split Stereo to Mono”. Then delete the silent track (click on the [X] in the top left corner of the track).

thank you !! it worked ! finally, thanks man !