Problem when recording while overdubbing is enabled

Like most computer software problems, worked yesterday, doesn’t work today :frowning:

I’m recording my guitar through my Line 6 Helix interface, I cannot record any new tracks while overdubbing is enabled. It records nothing but static, meter maxes out, sound wave bar shows maxed out static noise. Turn off overdubbing and I can record no problem.

I have an oculus rift headset and when I switch Audacity output speakers (line 6 helix) to oculus, I can record while overdubbing; however having an oculus on my face while recording is not optimal. Seems like my helix is having an issue doing the playback and recording at the same time? Not sure because I didn’t have this problem before using the same setup.

I’m using MME, Recording / playback in windows is set to Helix, Recording device in Audacity is set to Digital Audio Interface (line 6), playback speakers in audacity are set to Speakers (line 6 helix). sample rate at 96000. No other settings enabled under transport options. I’ve been messing with options / preferences for two nights now. I’m stumped :unamused:

Line 6 Helix floor model
Audacity 2.2.1
Windows 10 (up to date)
Custom Build Desktop @ I7-2700k / Asus p8z68 mobo / gtx 1080 / 16 gb ram / No soundcard -just realtek onboard for daily use.

All help is appreciated.
Thank you

Have you tried powering everything off and rebooting everything (everything)?

I once worked at a place where they had about 20 USB interfaces of one particular model (not Line 6), that were forever giving this type of problem.
Usually, turning off the computer and the Interface, then rebooting would fix it. Sometimes it didn’t, then I’d need to:

  1. Exit Audacity
  2. “Safely remove hardware” for the USB interface
  3. Physically unplug and power off the interface
  4. Reconnect the interface
  5. Power on the interface
  6. Wait for Windows to fully load the interface drivers and connect to the interface.
  7. Restart Audacity.

Hey Steve,

Thanks for your reply. I’ve done multiple restarts and shut downs. I uninstalled my helix drivers and reinstalled them. Line 6 Helix drivers are very minimal so it was really easy. Unfortunately I’m still running into the same problem :frowning:

Any other ideas?


Start a new Audacity project with the sample rate set to 44100 or 48000 (try both).

Hey Steve,

I tried that, it didn’t work. So I ended up reformatting my PC. That fixed it for now. My guess is it was a driver issue with my mobo that was causing the problem. However, I have really no idea. But thank you for the help my dude.