Problem when export (add noise)

Hello all, This is my problem : I recorded a sound with some noise, I did the function “remove noise” etc this works very well I have a clear sound with no noise in audacity. But when I export in MP3 and I listen the sound there is a problem, the noise is come back as the same as before. I don’t understand what i have to do to export with the exact sound as they are in audacity.

Thank you very much.

I found the solution here :

That is only a partial solution.
Normally dither should be enabled as it provides better sound quality (less distortion) than disabling it, However it has recently been discovered that the default dither settings do not work correctly when exporting stereo tracks and the dither noise is much higher than it should be (thus it is noticeable when it should be inaudible). This has been fixed now and will be correct in Audacity 2.0.5 which is due to be released soon.

Probably the best workaround at present is to set the “High Quality” settings to use “Triangle” dither as this is almost as good as “shaped” dither should be.
If you prefer you can turn dither off, but there will be a slight increase in harmonic distortion, but considering the sound quality losses inherent in MP3 format, the little extra harmonic distortion will probably not be noticeable (you may notice it if you listen really closely to the very end of a slow fade-out).

You’re right triangle is better than none but none is better than default.

Thank you very much.