Problem w/ Skips in Recorded Tracks


New here. I am using a 2014 MacBook Pro with OS Sierra 10.12. I am using Audacity 2.0.5 with one of the little walkman style cassette to digital converters. It is called “Super USB Cassette Capture.”

I have had a few problems with it but have managed to convert a few of my old cassettes. The latest problem is as follows:

I do everything as I had done with the successful conversions. I open Audacity, put in the cassette, push the record button on Audacity and start the cassette playing.
I leave it to record and come back later. The music is recorded, and some tracks are fine. But some tracks skip around upon playback. In other words there is a second or two of music which skips to another part of the song, or another song. This happens several times. It is as if you are listening on a CD player that is not functioning correctly, except that you can see on Audacity that the recording itself is not skipping. So the music has been recorded with the skipping around somehow. The affected tracks are unlistenable and useless.

Thoughts as to what’s going on here and how to avoid it?


That’s ancient and should be updated. The current version is 2.1.2 and is available here:

What’s changed since your successful recordings?

The first thing I’d try is rebooting (with the option to reopen current applications OFF / not selected).

Hi Steve, thanks for the reply. I didn’t change anything between the successful and problem conversions. I also have re-booted my computer several times since it happened. But I did just download that more recent Audacity, so I’ll re-boot again and maybe try converting the same cassette again.

Using the newer version of Audacity, I made several more conversions of a couple of different cassettes. Same results. Some of the music is fine, but there are multiple places where tracks skip around or cut off before the end. Very frustrating. Not sure if it’s Audacity or the device I’m using or a combination.

It may be due to the “buffer” settings.
The default “Audio to buffer” setting is 100 ms. Try setting it to a slightly smaller number. You may need to try several values to find what works best. Try reducing it in steps of 10 ms and make a test recording each time. If the setting is too small the problem will get worse or refuse to record at all.

How do I change the the buffer setting?

And another question-is it possible that clipping due to high input volume would cause bits of the track to drop out?

Okay I found out how to change the buffer setting and also found more suggestions for this problem in the Audacity troubleshooting section. I have tried lowering the buffer setting, along with changing the sample rate and changing from stereo to mono. I also have tried a different USB cable. Same results. I’m close to giving up.

“Audio to buffer” may need to be set to zero or as low as you can get it so that the recording cursor moves along.

Can you attach a short sample of problem recording? Please see here for how to attach files:

If pieces of recording are being time shifted around and mixed in with each other, that probably isn’t to do with buffer. Koz here had that once or twice but never again. Or the digital (USB) output of your device could be broken.

Does this device have headphones out? Is this your Mac If so unfortunately you can’t record into it properly from any analogue output of the USB device because that Mac does not have a proper stereo line in.