Problem upgrading to 2.4.2

Windows 10 Pro 64 bit.
I have been running Audacity 2.3.1 successfully for some time and today upgraded to 2.4.2
On opening Audacity 2.4.2 I get “Internal PortAudio Error” and will not see any of my audio devices and, therefore will not play back.
I have tried all the advice I have been able to Google (youtube etc) and have updated all my drivers etc but I still get the same problem.
I have uninstalled 2.4.2 and reinstalled 2.3.1 which is working fine.
Grateful for your thoughts.

By the way - I did rescan for audio devices.

What settings are you using in the Device Toolbar with Audacity 2.3.1?

Thanks Steve. I attach a screen shot from 2.3.1 which I hope answers your question.

Sorry I should have said, I am importing the audio off a video which I have open in Adobe Premiere Elements so that works fine. But when I come to try to play it, Audacity 2.4.2 tells me that no audio devices are detected (or words to that effect).

If you close Adobe Premiere Elements, and then restart Audacity, are you able to play audio in Audacity?

in 2.3.1 - yes
in 2.4.2 - no - I can see the wave form quite clearly and can edit it and export it, but I can not play it.

I assume that you have exactly the same settings in the Device Toolbar in both versions of Audacity?

Thanks again Steve. I have just done a fresh install of 2.4.2 in a different directory (so I have kept 2.3.1 intact).
There is nothing to show in the toolbar - all windows are greyed out even if I click on the arrow for the drop down list. It drops down but there is nothing in it. Please see attached
. 2.3.1 continues to work perfectly!

Strange. Did you download Audacity 2.4.2 from here:


Not to worry Steve. I use Audacity to clean up sound and make a stereo track for training videos for our language school. 2.3.1 does that perfectly and I only tried to upgrade as I always like to have the latest version of any software I am using. I would like the developers to be aware of my problem for future planning but it is not critical. I am not going to moan that such a brilliant piece of free software doesn’t run on my machine when the alternative (2.3.1) works fine for what I need.


If you’d like to try a slightly newer version than 2.3.1, you can get Audacity 2.3.3 from here, and I expect this will work on your computer:

Thanks Steve. But this one works so I’ll probably stick with it.

Thanks again for your help - I hope it gets sorted in the next version.


I assume no one has any further thoughts on this. 2.3.1 is working fine but I always like to use the latest edition of any software.

If anyone has any thoughts, I would be grateful. Drivers are all very much up to date.