Problem Setting Record Level

I’m new to Audacity and need some help. I’ve become interested in digitizing old 78 records. I’m using a cheapie turntable with a USB connection to my Mac. Recording is in mono. The oddest thing keeps happening and I don’t know what to do about it. After I set the record volume, it moves to another level on it’s own. For example, if I set the level to 0.10 it will jump over to 0.07 or 0.13. I’ve tried the slider and tried clicking on the record volume to set it but it continues to move over on it’s own. It seems to favor 0.07 and 0.13. Am I missing something here? How do I adjust the record volume to what is needed and have it stay put? Thanks in advance for any and all help.

With a USB connection the recording volume should not be adjustable at all.

What are your settings in the Device Toolbar?

– Bill

Thanks for your response. The settings are core audio, USB microphone, 1 mono - 2 stereo, built in output. In addition, there’s a recording volume slider and a playback volume slider. The sliders do work. The recording volume slider can be set but always moves away from the place where I set it.
For example, if I set it at 0.10, a second or two later it jumps to 0.07 or 0.13. It’s puzzling. Your suggestions are appreciated.