Problem recording multiple tracks

System: Windows 10
Audacity version: 2.3.1
Audio interface: Line 6 Pod Studio UX2

First of all, I wish to comment that this is something I had already done in my old computer with windows 7 and a previous version of Audacity (I think it was 2.1.0), using the same audio interface to record voices and guitars on multiple tracks (up to 8 or 10 in some projects), and I had never found these problems.

In my new computer I installed the new version of audacity, and when I tried to record vocals using a music track, the record was not correct (clipped) and a new track with “loses” was generated, with a message saying something about the use of memory or something like that (it was in Spanish, sorry). The same happened when I tried to record guitars. However, this did not happen when I recorded directly in a new single track project.

I attempted another method, listening the backing track in youtube and recording the vocals in a single track audacity project. Then, I tried to combine those tracks “a posteriori”. However, my surprise was that the speed of both tracks was different.

Any solution for this?
Thanks in advance.

I don’t understand what you mean. Are you referring to this: Recording - Audacity Manual