problem playing sound

I am using Audacity 2.0.5, installed by the Ubuntu package.
I open any mp3 file and then play it using output device HDA Intel: VT2020 Analog (hw: 0,0).
The sound seems to be at the right speed but is a bit distorted.

However, if I play the mp3 with mplayer, it sounds right

Is it the same noise you complain about in recordings https://forum.audacityteam.org/t/unwanted-noise-on-recording/35256/10 ?


Gale

No, this problem occurs even when I play an mp3 produced by someone else

We can’t see or hear your computer, obviously.

So this noise only occurs playing MP3’s in Audacity, right? What device is mplayer playing to?

Is it possible to record the playback noise then post an audio sample ?

Are you using too high a project rate? Sometimes 48000 Hz is best on Linux. Are your Audacity tracks at the same rate as the project rate? Are you using too low a buffer setting in Recording Preferences? That setting affects playback too.


Gale

okay I changed “Audio to buffer” to 200 and it now plays correctly.

Is that a reasonable approach?

Anything that works is reasonable if it has no bad consequences elsewhere. You don’t need to worry about Audio to buffer being higher as long as you are not doing overdub recordings in Audacity or as long as you aren’t streaming the Audacity recording to your SIP client for your show.


Gale

I am not doing overdubbing or streaming. So this looks like a good solution.
Thank you for the assistance

Is the reason I need to set this to 200 a known bug? Is it worth investigating?

Assuming I keep this setting, is it possible to combine two mp3s using audacity into a single file which has the sound of both combined?

If you had it set to something unreasonable like 20 before, no it’s not a bug. We have not heard the problem for ourselves so we don’t know what it is.

The “Audio to buffer” setting is not likely to be relevant to that unless you are importing a large number of tracks stacked on top of each other.

If you mean you want the files to play mixed together, that happens anyway. If you are trying to join the files end-to-end, see http://manual.audacityteam.org/o/man/faq_editing.html#join. If you are joining the files and no other editing, you should not even do it in Audacity because you will have the quality loss of re-encoding the file. Use something like Mp3Wrap instead, which joins MP3 files losslessly.


Gale