Problem opening Audacity project file

I’m having trouble opening a project file I saved yesterday. A quick scan of the forums shows this is a common problem, but I haven’t seen an issue exactly like mine.

Error Message

When I open the project, I get an error message telling me that it recognizes the file as an Audacity project, and then tells me to open it (basically doing what I just did).

I see that the main cause for project file problems is moving them and the data folder around, by I’ve left both of them in their original place, in the same destination.

I’m using Audacity 2.1.3. I have saved the files not in my C drive, but in the partition. Does that normally cause an issue?

What does that mean? That sounds like it ‘may’ be a problem.

Sorry, I’m not great with terminology. My hard disk has multiple partitions, and I’ve installed audacity and saved the project files to the D: drive. However I have a previous file saved there that opens fine, so I don’t that’s what’s causing this issue.

If that is an internal hard drive, then that’s unlikely to be the problem.

The issue sounds much like this problem: Please Help! Lost a song
If you could upload the AUP file, I can take a look.

Sure thing, thanks.
TEO Podcast Episode 2.aup (404 KB)

Sorry to say, it’s much like the one in the other post, it’s just full of “NULL” bytes and so is not recoverable.
I’m not sure why this happens, though I’ve seen it a few times. My suspicion is that Windows, or a security product running on Windows, may be clearing “unused” data when the computer is asleep. Do you know if your computer went to sleep before the project was saved?

Ah, that sucks. But glad to have found the cause.

Well I did save the project originally, put the computer to sleep, and came back later to continue working. All was fine, but the second I put the computer to sleep I don’t know if I saved it or not.

I guess the best advice to take from this is to save and close the program before closing the laptop lid…

Thanks for the help.

And for desktop machines, turn off “sleep” and “hibernate”.