Problem from upgrading to 2.0.3

I successfully used version 1.3.14 and recently upgraded to 2.0.3. Unfortunately, the new version does not allow for a recording input of Microsoft Array USB PnP Audio Device, which is the only device that works with Audacity on my system. I have Windows Vista, and I installed Audacity 2.0.3 from .exe installer.
Does anyone have a solution for this problem?

Why not? What happens?
Which version of Windows?
What sort of computer is this?

When I use any of the recording devices in the pulldown menu, I get a deafening sound like an air raid alarm.
I am using Windows Vista.
The computer is an HP Pavillion for media. It works with all other media, and it worked with Audacity 1.3.14. The problem is, the new version of Audacity does not provide for recording with the Microphone Array USB PnP Audio Device.

Look in the Transport menu and ensure that “Software Playthrough” is NOT selected.

I think that worked. I get no sound when it’s recording, but I get sound with playback, and I can export it in usable form.