Problem capturing streaming audio

I originally downloaded Audacity to record from a USB cassette player I bought to put some old cassettes on CDs. It worked great! However, I ran into a problem when I tried capturing streaming audio. I am using Audacity version 2.0.5 on a Windows 7 machine that has onboard sound. After digging around in the manuals and FAQ for a couple of days, I have found that 1) downloading streaming audio can be difficult and 2) USB equipment can mess with Audacity. The last time I tried recording streaming audio was with my Cakewalk Sonar program, but I find now that it will not record either. I am wondering if using the USB recorder and my USB headphones (with built in mike) is causing all this. I have tried unplugging my headphones and disabling all USB devices from the Sound folder in Windows, but this has not helped. I do not get any input signal when trying to record. When using the MME Audio Host, I only have the input options of Microsoft sound mapper, line in, and microphone. I’ve tried all three while streaming online audio, but I don’t get an input signal from any of them. If I plug in a microphone, then I get a signal. Any ideas?

The ability to do this depends on your version of Windows and your drivers. With Windows 7, you should be able to use WASAPI Loopback. This Page shows you how to do that and gives you several other things you can try.

If all else fails, there are some software suggestions on the bottom of that page. Total Recorder (about $20) comes with it’s own drivers and it seems to work for most people.

Thanks DVDdoug. The page that linked to helped. What I ended up having to do was go into the Windows control panel and disable the USB support through the Device Manager. If I disabled it from the Sound tab (going through the speaker icon at the bottom of the Windows screen) it didn’t do the job. Of course, I’ll have to get myself another set of headphones so I can listen to the results without having to keep going back and forth to enable the USB sound support for my USB headphones, but this will work quite well. I really didn’t want to do the cable thing from In to Out, as I have done this with other equipment and have ruined a couple before getting it right. :astonished: Thanks again!

You should not need to disable USB support in Windows Device Manager.

If the USB cassette player is a problem when recording streaming audio, remove it from the computer.

If you want to record streaming audio that is playing through the USB headset, the only way to do that in Audacity is by using Windows WASAPI.

  1. Open Device Toolbar .
  2. In the first (Host) box of Device Toolbar, choose “Windows WASAPI”.
  3. In the second (Output device) box in Device Toolbar, choose the USB headset that you are using for listening.
  4. In the third (Input device) box in Device Toolbar, choose the (loopback) input for the USB headset.
  5. In the fourth (Input Channels) box in Device Toolbar, choose mono or stereo.
  6. Start playing the audio you want to record.
  7. Press the big red Record button in Audacity.


Thanks Gale. You know, I could have sworn I tried that without result, but I tried it again this morning and it worked :blush: I’m getting too old for this :unamused: