prevent time shift when pasting

With Preference unchecked for “Editing clips can move other clips” the track shifts when pasted. The segement is only a few seconds and I was pasting into a blank area of track. I read the help on pasting but did not understand “enough room for the pasted audio”

It’s better if you post in the section of the forum that relates to the version of Audacity that you are using, for example here is the forum for Audacity 1.3.x on Windows:

The information below applies ONLY to Audacity 1.3.x (the old 1.2.x versions cannot do this).

That applies to when you are pasting into an empty area of the track.

To demonstrate this,

  1. open a new Audacity project
  2. Generate a tone of 30 seconds duration (Generate menu)
  3. press the F5 key to switch to the “Time shift tool” (or select the double headed arrow button ( ↔ )
  4. Zoom out so that you can see a couple of minutes
  5. Click on the audio wave in the track and drag to the right so that there is a gap of about 1 minute to the left of the track.
  6. Press the F1 key to switch back to the normal “Selection” tool (or select the “I” button)
  7. Double click on the waveform to select it
  8. Press Ctrl+C to copy it (or select “Copy” from the Edit menu)
  9. Click near the beginning of the track (anywhere around the 10 second mark)
  10. Press Ctrl+V to paste (or select “Paste” from the Edit menu)

Try this with and without “Editing clips can move other clips” enabled.

I’m not sure exactly which bit of the documentation you are looking at, but I presume that “enough room for the pasted audio” means that the “gap” that we made in step 5 needs to be big enough for the audio we are pasting.

In most cases it is not necessary to paste into an existing track.
If you wish to replace one section of a track with some new audio, put the new audio on a new track, use the “Time Shift tool” to slide it left/right to the correct place, then either use “Split Delete” from the edit menu to remove the unwanted audio from the original track, or use “Silence Audio” (Ctrl+L) to make it silent, or if you want it to be adjustable, use the “Envelope Tool” to silence the appropriate part.
Envelope tool:

Using any of these methods allows yo to very precisely adjust the position of the audio. You could even create a “cross-fade” so that each audio segment fades into the next.

I can now paste into another track without time shift. When I tried before, I was copying from a split audio track to a mono track. This was also what I was doing when I asked in another post why I could not move a clip to another track using time shift.