Premature clipping when recording

Audacity 2.0.1 installed from Debian repository
Debain wheezy, 3.2.0-4-686-pae kernel
Diamond Xtreme Sound 5.1 sound card


I am getting what seems to be premature clipping. My Audacity recording level meters appear to hit a maximum at a point which is determined by the position of the pavucontrol recording level setting. At this point, the recording level meters behave as I am used* to seeing them behave at the very end of the range (0 Db level). That is, they stop as though against an (invisible) limit, and the dark red (right-most portion) compresses. Also, I am getting what I believe are the clipping indicators (blue bars) wherever this apparent limit is reached.

When I record the wave trace does not fill the whole window vertically, but clips (is flat, squared off).

As I said, the point at which it reaches this limit is determined by the level in pavucontrol. Contrarily in pavucontrol, however, if I push the level all the way to the max (153%), there is still a limit about 5/6 of the way where the pavucontrol level indicator will not exceed, and appears to flatten there (clipping).

On a previous thread where I got my recording working, I was told this can be sound card specific. I just purchased this one, which was on the cheap side. (There were limited choices. I had just returned an CS Audigy one that was the wrong PCI-type, and this one featured Audacity on the back of the box!) Please also let me know if you have any (regular PCI) sound card recommendations or know of any issues with this one.

*Note: this is new linux installation and new sound card. Previously, I used Audacity on Windows XP with a Sound Blaster 3.0 sound card.


You could have something as simple as plugging a high-level, stereo sound signal into a low-level, mono, Mic-In on the sound card. The Mic-In electronics are overwhelmed and clip the signal way before the rest of the sound card, the computer or Audacity can get to it.

This is a common problem on Windows Laptop machines which typically have no Stereo Line-In (usually blue).

So it’s good to know exactly what you’re doing before you start tearing the computer apart. What is the job?


Hi Koz,

Thanks for the response. Sorry for the ommission. Btw, it is a linux desktop machine.

This issue is while trying to record streaming (from browser), which is all I have tried up to now. Attached is screenshot of what I described.
In this case the blue level indicator in pavucontrol is going all the way to the right, which is different than I was seeing previously, it seeming to max out 5/6 of the way.



So you’re right out of my world. I’m not a Linux dude. You need someone who understands Linux routing and audio software.


Hi. Guessing no one’s got much of a handle on this one. Looks like I’ll be trying a different sound card at some point.

So you’ve got the recording level turned up to 137%, the pavucontrol meter is maxed out, and you don’t know why it’s clipping? :confused:


Already tried/covered that. Increasing the pavucontrol levels to full is the only way to increase the max sound level (i.e. to increase the point where it hits the imaginary boundary). Even at lower levels, it still clips, but just at a lower level. See attached, flattened pulse wave. That’s what I meant by “premature”. It clips at less than full level.

Note (at this pavucontrol recording level) the audacity levels will never exceed that ~-11 point. Just flattens there and clips.

Try turning down the level of the thing that you are trying to record. If the audio that is playing is clipped, then the recording will be clipped (flat topped) regardless of the recording level.

I think that might’ve done it. Turned it down and now it looks like what I am used to seeing. Playback had been at 100% before, but guess that might’ve been too high. Thanks! :slight_smile: