Preferences while recording vocal

I’m fairly new to Audacity. I’m trying to record a vocal over accompaniment that I composed, in mpeg form. Using a good external mike through a mixer board. Can’t get preferences correct. I want to hear the accompaniment on one stereo track, thru headphones, while recording vocal on another. The best sound occurs when these are checked: Play other tracks while recording (overdub), Record on a new track, and Detect dropouts. Software playthrough of input is not checked. When I check it I hear a horrendous screech. The main problem is, on playback I hear the accompaniment on the vocal track with my voice, through my headphones, and it seems to be recorded on the vocal track. What am I doing wrong? How do I put accompaniment on one track, and vocal separately on another? Using Mac OS 10.14 Mojave, and Audacity 2.3.0. Thanks… Tom in Texas

Does this tutorial help?

– Bill

It helps somewhat. However, something still eludes me. I’m still recording accompaniment on the vocal track. Accompaniment is on its own track, and also being recorded along with my voice on the vocal track. I don’t know how to separate the two.

You can get this effect if you’re not recording from a real thing. Look at the device toolbar and make sure you’re recording from a thing you can touch. What does it say next to the microphone symbol? USB Audio CODEC, for example is the digital name for my microphone interface. I can reach out and touch it.

There are magic recording devices designed to record from internet or YouTube music. Those are not “real.” They are internal sound management programs. I can’t touch them.

One way to know you have one of them selected by accident is double recording in Overdubbing.

Another way to get “help” when you’re recording is leave Skype or other Chat program running by accident. They’re famous for messing with sound settings.


I’m trying to solve this by process of elimination. Trying every possible configuration of Preferences. It seems the problem is in Audacity Preferences>Devices. When Recording Device is set to Built-in Microphone, it works fine. But when I switch to the only other alternative, Apowersoft_AudioDevice, my voice does not record at all. I’m trying to record with a Shure mike plugged into a mixer board with a USB interface.

Wait! I may have fixed it. Set all recording preferences on USB AUDIO CODEC, plug it all in and turn in all on BEFORE launching Audacity, and …what else? I have no idea why it’s working now but wasn’t yesterday. I’d better hurry and make my recordings before the demons possess it again. Thanks! TnT

Ok…recording again…and once again hearing the accompaniment in the background of my vocal. I have no idea why. While playing back I reduce the volume all the way on the accompaniment track, playing only the vocal track, and I hear the accompaniment. I turn the vocal volume down, and the accompaniment goes down with it. Everything microphone-related is set to USB AUDIO CODEC. Again…I’m recording thru a USB enabled mixer, and a Shure microphone plugged into it. If you are recording on a Mac similar to mine, please tell me your Preferences and Settings. This is driving me sane. TnT

I am wondering if the problem is in the fact that I’m recording through a mixer board. The mike is plugged into the mixer, as is my computer. The mixer is USB enabled. When I’m recording, is it somehow picking up the accompaniment because it’s being channeled through the mixer? Is the answer wiring the mike directly to the computer, via a USB interface? TnT

I am wondering if the problem is in the fact that I’m recording through a mixer board.

That’s terrific troubleshooting. Nobody ever gets it that far. There’s a place for you here on the forum.

Many mixers have a button called “USB To Main” or something similar. So yes, it’s totally possible you are accidentally sending the backing track down the show pathway along with your voice.

Did you tell us what the mixer was?


Thanks for the encouraging word. But right now I feel pretty dense. The answer is right in front of me. I just can’t find it. The board is a small one, an Alexis Multimix 4 USBFX. I have a larger one–a Behringer XenyxQX1832USB, but it is way too much mixer for me. However, if it would work for this I’d use it.


And yes, the mixer does have a button EXT/USB to MAIN.

Alexis Multimix 4 USBFX.

I looked at the instructions and they seem to suggest you can leave USB To Mix unselected and use the mixer as a USB monitor or microphone live monitor. They never quite get around to saying you can do it both at once.

Try it.

Many larger mixers are just six, eight and twelve mixers glues together. You’d be amazed how much of one you can turn off.

Those three knobs are the only ones used on this mixer (plus headphone volume). Everything else is neutralized, zeroed out or turned off.


You may be “stuck” with your larger mixer. See where it allows you to assign USB and main mix to headphones and at the same time turn USB to Main off?

Screen Shot 2018-10-23 at 16.37.52.png

That’s your overdubbing setup.

But try the smaller mixer first. They insist you can listen to your USB return.


How did you become “cursed” with a Behringer mixer? If you don’t want it I’ll take it. Really, it’s no trouble.


Thank you for the thought you have put into this! I’m getting ready to monkey with it, as you suggested. Yeah, I bought the Behringer not knowing very much. Had a high school reunion where a folk group I was in sang, and used it for that. Haven’t used it since, and I’d about decided to sell it. It’s too much mixer for me. TnT

GLORY! This morning I finally figured it out, tho I’m still not sure why it works. The little mixer won’t work. I resorted to my dreaded larger Behringer mixer, and have been fiddling and toggling switches all morning. Finally it came down to the channel 7 / 8 that the accompaniment is fed into. Next to each channel are three buttons: Solo, Sub and Main. Main has to be up, or off. When it’s pressed in I can hear the accompaniment behind the vocal track. When it’s up, none! Thanks for your help! Guess I’m stick with the Behringer for awhile longer.

Tom in Texas

Finally it came down to the channel 7 / 8 that the accompaniment is fed into.

I wish I had caught that earlier. You’re calling “accompaniment” the backing or sync track? You don’t feed the backing track into the mixer as a sound signal. It naturally comes up the USB cable from the computer.

You set up Audacity so its play service and record service are both the Mixer USB. When you do that, the backing track doesn’t appear at any of the mixer sound channel sliders, but instead appears at those two red buttons to the right. Do Not press USB/2 TR that mixes the backing track with the show, and Do press the USB/2TR button that allows you to hear the backing track and the show mixed in your headphones.

This is what happens when technical support is on-line only and multiple time zones away.

You may get to re-do the latency timing tests so your live performance matches the time and beat of your backing track. That’s where you record for overdub and jam your headphones against the microphone.

The latency correction is the different between the two tracks. That’s generally done with a click track.

This is before. The backing track is on the top-left and the badly recorded performance is on the bottom-right

…and this is after perfect correction.

Are you following along with the Overdubbing setup? This is in the section called Recording Latency.

It occurs to me you should try the small mixer again now that you know the USB cable trick.


Wow, this is all new to me. Thank you for your thought and patience, and your explanation. I’m printing it, so that I can read it several times while recording. Going to go in there right now and monkey with it, with this in mind.


You were fuzzy/foggy until you said you had connected the backing track to mixer 7/8. Ding! That’s not how it works.

If you set the smaller mixer as both playback and record USB devices, it may start working, too. Play something in Audacity and you should be able to listen to it on the mixer headphones with just the USB cable connected.