Preferences: Libraries buttons grayed out

I’m running the latest Debian Jessie 64bit and installed Audacity. I noticed when I place a m4v audio, it will not decode it. After doing some searching, I found that I should point audacity to LAME and FFMPEG libraries, but when I go to Edit > Preferences > Libraries, all options (“Locate…” and “Download”) for the MP3 export library and FFmpeg import/export library are grayed out. Can anyone help me with this? I have the latest version (3.99.5) of LAME and FFmpeg installed…I’m at a loss.

PS~ forgot to add that I installed my distribution’s version of Audacity which is 2.0.5

LAME is only for MP3 export.

As it says in the Manual: Audacity Manual

Some Linux distributions (for example, Ubuntu) now package Audacity with MP3 encoding and FFmpeg support already linked dynamically to the relevant system libraries. In these packaged builds there is no need to locate LAME or FFmpeg, so Audacity will have no “Libraries” Preferences.

That should apply to Debian packaged builds too as far as I know, that is, there won’t be any LIbraries Preferences.

However as far as I know Debian “Jessie” is unstable / testing. It is recommended to install stable releases of Debian.

Are there any F, C, U numbers given in the Libraries Preferences opposite “FFmpeg Library Version”? If yes, what is the exact error when you import the video? Are you sure that video actually has audio? The extension suggests that it might not.

If there are no F, C, U (or LAME) version numbers this may suggest that libmp3lame (what Audacity is looking for) is not actually installed and that FFmpeg support was not enabled in the Audacity build you have.

If you cannot find libmp3lame in the repositories you may need to need to add an appropriate entry to your sources.list. It may be called “debian main non-free”, “debian-multimedia” or similar.


Thank you so much for your reply!

Ok, so I can import mp3, just not .m4a. There are no F, C or U numbers when looking at the library from Audacity. In case I’m wrong, I’ve attached a screen shot. Also, I’ve attached the screen shot of the error I receive when trying to import the m4a file. It’s a recording done (presumably on a Mac) so it’s not a video, so not sure why it has the m4a extension, but that seems trivial.

Audacity error and Preferences:

You gave “M4V” for the file extension, hence I thought it might be a video file without audio. The M4A extension is correct for a file containing AAC audio.

Thanks for the screenshot which makes clear that the Audacity build does not have FFmpeg support compiled in (but can export MP3 files). This is the penalty of using unstable releases of distros. If you must use “Jessie” then you will need to compile Audacity yourself with FFmpeg support enabled. However, FFmpeg is enabled by default in our code, so building Audacity with default configuration will enable FFmpeg.

Steps for compiling the latest 2.0.6-alpha Audacity source code are here: . It is best to uninstall the packaged version of Audacity before compiling and installing Audacity from the source code.


Excellent! I’ll try to compile as I must use Jessie for some work-related packages that are not up-to-date/available in Wheezy for work. I’ll post the outcome before marking this as solved

I should add that Audacity won’t compile against higher than FFmpeg 0.8.

If you already have a later FFmpeg version than that, it may be simpler just to use FFmpeg at the command-line to convert the M4A file to WAV for usage in Audacity.

ffmpeg -i filename.m4a filename.wav

will produce a 44100 Hz 16-bit WAV file with the same number of channels as the M4A.


I’ve tried to compile Audacity now, but get the following error:

libtool: link: cannot determine absolute directory name of `@libdir@'
make[1]: *** [audacity] Error 1
make[1]: Leaving directory `/home/npost/AdditionalApps/audacity-read-only/src'
make: *** [install-recursive] Error 1

Does this mean I need to create a libdir or am missing dependencies?

I’m trying it now. Back soon.

I’m getting the same error on Jessie and I don’t know what is causing it.
I’ll post again if I find out anything. Please do likewise :wink:

I’ve just had a reply from one of the developers (not had chance to test it yet):

I investigated the bug and found out, that this issue was caused by a
bug in vamp-plugin-sdk 2.5+repack0-1. I fixed the bug in vamp-plugin-sdk
2.5+repack0-1 and uploaded 2.5+repack0-2 to Debian unstable. Please
update the package and then you can build audacity again.

Long story:
$ pkg-config --libs vamp-hostsdk
returns the linker flags for this library. The faulty version of
vamp-plugin-sdk returns “-L@libdir@ -lvamp-hostsdk -ldl”. -L specifies a
library search directory and should be a existing path, but is @libdir@
in this case. @libdir@ should have been replaced with /usr/lib (or
whatever you configured the library). libtool tries to determine the
absolute path of @libdir@, but obviously fails to do that.

I took the easy way out: I backed up everything and reinstalled my OS. Now it’s working. I should note though that I installed Wheezy, then installed the Wheezy package Audacity, then updated my sources.list to Jessie.

vamp-plugin-sdk has now been updated in Jessie, so the problem “should” now be fixed. (I’ve not tested yet).

Just tested it. Audacity now builds on Debian testing (Jessie), though for a “production machine” I’d still recommend using Debian stable.