preferences clavinova using midi cables

Windows 7 - audacity version 2.1.2 - .exe
I just started with audacity. I’m trying to connect my Yamaha clavinova to my laptop, using a cable with on the one end two midi connectors that go into the piano (midi out and midi in), which on the other end join into one usb that goes into the laptop.
Using this configuration, I don’t know at all how to set the preferences in Audacity and I couldn’t find it in the FAQ. Can anybody help me with that ?
Many thanks in advance

Audacity can’t record MIDI. Audacity only records audio (MIDI is not audio:

To record the Clavinova in Audacity you need to connect an audio output from the Clavinova to a “stereo line input” of the computer. See here for more information:

And if the instrument doesn’t have a stereo audio connection, you do what I do and use the headphone connection. I split it off to speakers and headphones, too, so I can hear what I’m doing in real time. If your computer has no stereo audio input (many don’t) then you can use a stereo USB device such as the Behringer UCA-202. substitute your instrument for my mixer.


The Behringer is certified to work in overdubbing mode should you decide to record sound-on-sound performances.


Thanks everybody for your answers !
I’m now trying to do this with the AUX OUT of the clavinova, so using two thick jacks (if that’s the correct name for those things) on the side of the piano, and these go into my laptop through one smaller jack, into the microphone entrance. When I listen to the recording, sound is still not good and I can hear every sound around me. So audacity is not just recording the sound from the piano through the cables, but also all the sounds in the room.
What am I doing wrong now ?
Maybe something is wrong with the options in the program itself ? The options remain grey, so I can’t even change anything.

Audacity isn’t doing that. The Windows mixer is.

First look at possible sources and disable what you don’t need, such as the laptop’s internal mic:

Then launch Audacity and select the line input as your recording source:

Then record again and see how the sound turns out.

Missed one. Chances are good the high volume signal at the headphone connection is going to overload the Mic-In of the laptop. That sounds crunchy or sometimes you get blue waves that only go half-way up. They stop at 50%. If you don’t have a blue Stereo Line-In (most machines don’t), then you’re stuck with a USB interface.

You might well think you can just reduce the volume of the keyboard, but many people find the volume control runs the thickness of tissue paper up from all the way off to force this to work. And then you still only get half volume.

Much better with the USB adapter.


ref Cyrano’s message:
*) internal mic: I tried to disable the laptop’s internal mic, following the links in your message. Thing is my Windows is in French so sometimes I have to guess my way through things, but I did this: I disabled/disconnected something called “microphone network (“réseau de microphones”) IDT High Definition Audio CODEC”. You think that’s the internal mic ? I’m going the do a recording, see what it sounds like.
*) recording source: I tried to select the line input as the recording source.
What I have in my preferences now is:
host: MME, using portaudio V19-devel
device: speakers / entry line IDT
device: microphone / entry line IDT
channels: 2 (stereo)
I’m going to record some piano now.

ref Koz’ message:
I’m not using the headphone connection on the piano but the AUX L and R, using those thick jack sockets (6,35 mm). Will I still have the problem you’re mentioning and therefore need the USB adaptor ?


Strange: when I have Audacity on Rec and Pause, the mic volume signal (which now should indicate only the volume of the piano I suppose) vibrates constantly and reaches 54, when I’m NOT playing.
Is this normal ? I suppose it’s not supposed to be like that.
I’m using the options and cables as described in my last message.

Koz: about the USB-adaptor (the Behringer), I can’t use that to connect my piano’s Midi signal to the computer right ? Even using the Behringer, the Midi signal remains something that Audacity can’t read right ?

Yes that is the “microphone array” (internal microphone).

So those AUX are red and white (RCA)?

Even if that microphone is a stereo input and you connected an RCA to stereo TRS cable to that input, it will almost certainly not sound as good as connecting to the UCA 202 or similar interface.


OK, I just did a test and you can’t hear any surrounding noise anymore. That’s good news. But there’s a soft and very high but disturbing electrical zzz-like noise. Any idea what that could be ?

Hi Gale
Yes, the jacks that go into those AUX have a red and white band. They’re like the picture I uploaded to this message. And they go directly into the mic entrance.
So I should use a USB-adapter like the UCA-202 to have a better sound ?

Un-necessary amplification because you are connecting to the wrong type of port? Did you get a stereo result where the Audacity left-hand playback meter dances differently to the right-hand meter?

Perhaps you could post a sample of the zzz-noise.


Gale, I’m attaching the zzz noise to this message, hope it works.
The piano I recorded sounds stereo and there is a difference between the left hand and right hand meter, when not playing and only having the noise. You need your head phones to hear it really well.

That’s your computer and maybe some lesser shielded cables.

A decent USB interface would probably solve that. It might pick up other noise, depending on your computer. Some laptops are not suited for audio, I’m afraid. But if you buy from a shop that lets you return stuff, you can test without too much hassle.

Besides the already mentioned UCA202, the UMC202HD is only 50$ now, direct from Behringer:

If you’d ever wanted to sing and record, it has 2 “Midas-like” microphone preamps.

Hi Gale
Yes, I also want to sing and add rythm-like sounds (rythmical scratchings on things). Behringer still best option ?

Your recording of the piano was stereo, so you have one of the “compatible” mic inputs that can accept line level.

You can get rid of a lot of the noise with Audacity’s Noise Reduction without significantly harming the piano.

I agree with cyrano the UMC 202 HD seems a good bet - you could record keyboard and voice at the same time with that. You might get a different sort of whine or crackly noise with that, but probably a little lower than the current noise with the mic input, and the quality would be better.


It’s only 2 channels, so recording microphone and keyboards in stereo simultaneously wouldn’t be possible.

But you could first record keyboard in stereo, play that back and sing along.

If you need to record the keyboard in stereo and simultaneously record the microphone, you’d need a 4 channel interface, like the UCM404 or UCM404 HD

True, of course. But you could use the Audio Track Dropdown menu to Split Stereo to Mono, then use the L…R pan slider on each track to adjust their positions in the stereo field.


Those are convenient shortcuts. There’s always the actual mixer option. The small mixer shown will mix four microphones and one stereo instrument (or combinations) into a stereo show. Digitize and record. The down side there is no ability to take it apart and remix it later.

This mixer is no longer available, but the Behringer 802 is still a current product and will do similar tricks.

Both mixers have analog outputs and need a digitizer for recording in Audacity.

If the UCA202 is used for digitizing, either setup can be used in perfect overdubbing; listen to yourself in real time and the recorded bed and rhythm tracks.