Powered speaker

I have an annoying problem. I am running KEF X300A powered speakers on my Mac Pro / OS Sierra. When I import a song to Audacity, it will play a few times through my KEF’s then kick it out to my mono computer speaker. Can’t reset back to KEF’s unless I re boot application. It ultimately does the same thing. I am running the latest version of Audacity. Any insight would be appreciated. Thx!

Are you using a wired or wireless connection to the speakers? If wireless, try wired.
My guess is that you’re trying to run them wireless but the connection is not 100%.
If Audacity loses its connection to the speakers, then you could try “Rescan audio devices” from the Transport menu to see if Audacity can find them again.

It sounds like the machine is losing contact with the speakers. The Mac will revert to something “safe” such as the built-ins.

Do you have a really long USB cable? USB isn’t much good beyond 4 to 6 feet. If you have cheap cables, not even that.


That’s a driver problem. KEF is in the same boat as Sennheiser. Maybe they got their audio driver from the same source?

Bottom line; don’t buy these. They should be USB 2 Audio class compliant, but that standard is a mess. USB1 Audio class was super solid, its descendant isn’t. I suppose that’s why Microsoft doesn’t even include this driver in Windows 10 anymore.

And in general, speakers with a USB connection are as bad as mics with a USB connection. Run, don’t hide, when you see one…

Thanks for all the suggestions. It does bump a few times before losing connection and could have driver issues. The USB is the same one that came with the speakers and I thought they should be of a higher quality.The KEF’s were not cheap speakers.Yes, I realize USB is not optimal. I bought these speakers to run itunes off my mac Book. I have not had a problem with them kicking out in itunes. Thought maybe it was an Audacity issue and not the KEF driver.

What is your actual Audacity version (all three numbers from Audacity > About Audacity…)?

If it is an Audacity issue, the most likely problem is the “Audio to buffer” setting in Recording Preferences (it affects playback too).

If you have Audacity 2.0.4 or later and the Audio to buffer setting is on 100, try reducing it to 0. If playback stutters, increase it in 10 millisecond increments until it doesn’t stutter.

If the setting is already well below 100, try increasing it.


Thanks Gale. I have Audacity version 2.1.2. Audio to buffer is set to 100. I will try your suggestion on playback starting at 0. Your response is much appreciated.