Possible bug with 2i2 audio interface at startup

I noticed on multiple linux distro’s (currently xubuntu) that at startup my audio interface (focusrite 2i2) keeps restarting; it keeps clicking and clicking and the program is not starting. When I remove the cable and plug it back in audacity starts without problems. I 've tested this on multiple computers and it only happens when using this particular audio interface. Why is this happening and can i do something about it?

It sounds like there’s an initialization problem in the device drivers. There’s probably not much you can do about it other than work out the easiest / quickest way to get it working.

Years ago I had some old m-audio USB devices on Windows Vista, with a similar problem. The best solution I found was to boot the computer first with the USB audio device turned off - wait until the computer had fully booted, then switch on the USB audio device - if the USB device was switched on during boot, the device wouldn’t work properly.

I’m sure this helps a lot … I have not seen this issue with my 2i2 on Kubuntu 20.04.

But do you mean startup of Audacity? Or startup of the OS? I haven’t tried restarting the OS with the 2i2 connected. (In fact I haven’t restarted the OS for 58 days.)

It is only when I start audacity. It keeps clicking but when I disconnect the usb cable and connect it again directly audacity starts normally.

It’s behaving weird. I waited this time for almost 30 seconds of clicking from the 2i2 and then audacity did start normally. Only the mic input lights on the mic knobs keep on like it’s receiving input but there is no mic connected.

In the terminal it reports: Expression ‘stream->playback.pcm’ failed in ‘src/hostapi/alsa/pa_linux_alsa.c’, line: 4628
Is this something that’s normal?

Where is the clicking audible / visible? In Audacity, or do you have monitor headphones in the 2i2?

What’s your exact sequence of connections? I normally keep the mic plugged into the interface so it’s:
mic plugged into interface
USB cable plugged into interface (still no power of course)
computer on

  • plug USB cable into computer (USB light comes on on the interface; pulseaudio recognises the interface and switches to it)
  • turn on 48V phantom power (mic gain light comes on)
  • launch Audacity
  • make sure recording device is 2i2
  • click to start monitoring, or just start recording (I have never had any problems - apart from forgetting things like phantom power!)