Possible bug auto record mode

I have the latest version 2.1.3 on windows 10. When i first starting using the program the record function worked normally, meaning i would open the program, hit the record button, and it would start recording immediately even though nothing was coming out of the speakers of my laptop. I could then activate an audio source from the internet, record whatever i wanted then stop it at any time. Approximately a week ago when i would open the program and hit record, it would not start recording. It would just put a red cursor at the “0” timeline and wait for an audio input, just as if the “sound activated recording” function had been turned on. But…when i look in the transport drop down the sound activated recording is not turned on. Is this a problem any knows how to fix ?

Can Audacity still see the recording device or software? I assume you’re recording on-line music or sound? Windows doesn’t naturally like to do that, so some device or special process must be installed. How did you make that work at the beginning?

VoiceMeeter Banana app will do that.


Hi Koz when i first started using the Audacity program i did not make any special changes to it, other than to set it to record any audio coming out of the speakers on my laptop. I would simply bring the program up and hit the record button. It would start the recording right away even though there wasn’t any audio coming out of the speakers. I would then access a video on Youtube that has music and the audacity session would capture whatever it heard and continue until i hit the stop button. I then could edit any unwanted space (dead air) at the beginning or the end of the file.

How exactly did you do that? Did you set it to record using “WASAPI loopback”?

If you are using Windows WASAPI loopback, start the audio player first. This may or may not be a recent change in Windows 10.

Once the player is started and stopped, then you can press Record in Audacity to record silence or lead-in before you start playing the stream.


I’ve also started experiencing this problem of the recording not starting if there’s no sound when using WASAPI. I’m also running Windows 10 Creators Update.
If I use Stereo Mix there is no problem, but for various reasons I’d prefer to use WASAPI.’

Your workaround of starting the recording, then stopping and restarting the playback from the start again works, but is not an ideal way to have to use the program.

The starting of recording even though there’s no sound is important to me.
It’s to overcome another Audacity fault which (and I may not be correct technically here) is that it doesn’t seem to be able to write fast enough at the start.
Consequently a word (for example) is often missed from a recording in those first (and only those first) few seconds.
If the recording of no sound takes place at the start I don’t experience this problem.

It seems to be a change by Microsoft that affects some sound cards. However how it works for you now is how Microsoft expects it to work, so it was “bug” before when recording started without the source endpoint being open.

The workarounds including using stereo mix are good.

Total Recorder may be another alternative which may or may not display the same behaviour. You could shop around.


Thanks Billy. You and i are experiencing exactly the same thing, including the “clipping” that occurs at the beginning of a recording. I tried the other settings, MME and Windows dierct. However those affect the quality of the sound when recording music. It makes it sound sort of hollow. I haven’t found a satisfactory solution yet. I agree the other suggested work arounds, though appreciated, are not perfect either.

That’s supposed to happen.
If there is nothing playing, then there should be no audio stream, and if there is no audio stream then there is nothing to record.
If recording happens when nothing is playing, then there is an active audio stream “from somewhere” that should not be present, and that is a bug. One possible explanation is that an application is running in the background that is playing “silence” or “almost silence”. The obvious danger there is that it could be introducing a small amount of noise into the recording. WASAPI loopback “should” be able to record exactly what is playing, no more and no less.

In most cases, (with well behaved sound card drivers), it is possible to press Record in Audacity, and Audacity will sit there waiting for the audio stream to start. Then start the audio stream and Audacity starts recording. That “should” work with no lost data at the start of the recording. If that’s not working for you, check to see if updated sound card drivers are available for your computer. Don’t rely on generic Windows drivers - For a branded computer with its built-in sound card, check the computer manufacturer’s website.
See here for more information about updating sound card drivers: http://wiki.audacityteam.org/wiki/Updating_Sound_Device_Drivers