Portable Preferences and Code Signing

On Mojave (10.14) the presence of the Portable Preferences folder prevents the ‘Audacity’ is an app from the internet, are you sure want to open it’ dialogue from appearing - instead it’s the ‘Audacity is damaged’ message (essentially there is no option to ‘un-quarantine’). The prefs folder works fine if you put it back into the app after it’s un-quarantined.

On Catalina the same app does not give you the ‘are you sure you want to open it’ message, prefs folder inside or not.

Essentially what I’m trying to do is make a version of audacity with modified preferences available to people directly. Since this seems like a developer signing thing, can I solve this by building from source?


ps - also tried right-click open, same results

Apple are now insisting that apps are digitally signed with an certificate issued by Apple, and notarized. This makes it rather difficult to distribute builds of open source software.

Thanks Steve that makes sense.

I made some progress with this by building with the prefs folder already in, just having some issues with build_dist.sh. Running this seems like a few parsing errors in the notarize function (for example: Entry, “notarization-upload:RequestUUID”, Does Not Exist). Some of these were solved by removing the \ escapes from xcrun altool arguments, but there are others, so still seems like I’m doing something wrong. Anyone see this before?

– Many Thanks