POD GX, Audacity 2.1.1 and Windows 10

I just installed Windows 10. I am recording using POD Farm and the LIne 6 GX TonePort interface. If I launch Audacity with POD Farm running, Audacity gives me an error message that says no audio device is connected. When I launch Audacity first and then launch POD Farm, my interface does not show up in the drop down lists for either sources or speakers. (Previously, I used it as both because it provides latency-free listening.) What can I do? I tried uninstalling and reinstalling Audacity, and I have already had to uninstall and reinstall my Line 6 software. I’m kinda stuck.

Hi staff,

Just registered and posting here to confirm que problem MrMike has. Actually i have to thanks him because i had my box plugged and everything was failing. His post helped me figure out everything was fine without the pod plugged.

Btw i personally have the TonePort UX1 (Another Line 6 product). Everything worked #1 on windows 7, audacity works great on my onboard card but meaning i cant play guitar while using audacity and cant actually record quick guitar riffs on audacity.

I assume the problem is with the line 6 drivers, but its hard to tell because everything else sound related works fine on windows 10. I actually had a problem configuring it (windows set it at 44hz 16-bit and i had to change for 48hz 16-bit to have windows sound)…

Guess someone will have to adress the issue at line 6 :S

Thanks again MrMike i can use audacity again.

Audacity does not yet officially support Windows 10.

Does the error message say PortAudio Initialization Error?

What happens if you launch Audacity, then start POD Farm, then try Transport > Rescan Audio Devices?

Have both of you been to Line 6, chosen “Windows 10”, clicked “Go” and installed the “Line 6 Monkey Installer Version 1.71 Released 7/23/15” which “adds support for Windows 10”? If not, try that.


The message says:
Could not find any audio devices.
You will not be able to play or record audio.

Error: Internal PortAudio error.

I tried your suggestion of rescanning audio devices, to no avail. I’ll try the new drivers.

Downloaded the update and installed it, and I’m still having the same problem. Alas, the operation was successful but the patient is still dead. :confused:
However, all is not lost. I still have my DigiTech GSP-1101 preamp that doubles as a recording interface and it appears that Audacity will still shake hands with it. The Line 6 is much easier to work with, but this is really just for doing demos and mapping out parts so it’s really not the end of the world.

Did you restart the computer?

If you make the Line 6 the default recording device and record with Windows Sound Recorder, does it record?


Nothing at this point. Ugh.