Pluginregistry.cfg missing in new Linux Mint build from src?

Just built new install on Linux Mint 18 and everytime I try to launch Audacity I’m getting immediate debug crash log window and Audacity not launching. Per the log:
00:06:28: Audacity 2.1.2
00:06:28: Error: Impossible to get permissions for file ‘/home/ericmint/.audacity-data/pluginregistry.cfg’ (error 2: No such file or directory)

checked the .audacity-data folder and that file is not there. Had previously tried making sure all permissions were read/write and the temp directory issue was corrected. But what is the deal with this? Can I just create a dummy file and hope it gets replaced when Audacity sees it?

also getting some other errors related to other apps when I launch audacity as sudo:

 sudo audacity

(Audacity:8772): Gtk-WARNING **: gtk_disable_setlocale() must be called before gtk_init()
Error opening file /usr/lib/lv2/carla.lv2/manifest.ttl (No such file or directory)
lilv_world_load_file(): error: Error loading file `file:///usr/lib/lv2/carla.lv2/manifest.ttl'
lilv_world_load_bundle(): error: Error reading file:///usr/lib/lv2/carla.lv2/manifest.ttl
no more csLADSPA plugins
VST_PATH not set, defaulting to /root/vst:/usr/local/lib/vst:/usr/lib/vst
ericmint-System-Product-Name testdisk-7.0  # cd /home/ericmint/.audacity-data/
ericmint-System-Product-Name .audacity-data # ls
audacity.cfg  Plug-Ins  pluginsettings.cfg
ericmint-System-Product-Name .audacity-data #


Check that the directory /home/ericmint/.audacity-data/ exists and has read & write permission for the user account.
Are you logged in as ericmint ?

On first ever run, pluginregistry.cfg is created by Audacity. On subsequent launches, if the file exists, Audacity will attempt to use it. If the file does not exist Audacity will attempt to create a new one.

Sounds like a permission problem, but could be due to a misnamed directory or you’re logged in with the wrong credentials.

It isnt launching even the first time. Immediately throws up the debug window and does not open. I checked the permissions first and it looks ok to me. It should be .audacity-data and not audacity-data right? Doesn’t the . imply that it’s hidden?
audacity-data Properties_005.png

here is the debug info that pops up. I also tried purging my install and installing from Mint repo and got exact same message. Does not open the first time. First time its launched I get the cannot find place for temp directory message. Then I’ve been directing it to a temp folder, creating it and then Audacity closes. On relaunch all I get is the debug error.
Debug report %22audacity%22_006.png (11.5 KB)

If there’s anything in .audacity-data that you need to keep, make a backup copy, then delete the entire .audacity-data folder. So long as you are logged in as the user “ericmint” and the permissions are not screwed up for “/home/ericmint”, then Audacity should recreate a new .audacity-data folder. This will essentially reset Audacity to “factory default” condition.

Isn’t sudo the cause of the problem? use sudo to install, not to make, and not to launch.


Well spotted Gale.

ok will clean out everything that’s there and lay off sudo to launch. i admit , being somewhat new to Linux, I brought some of my bad Windows habits of launching everything as admin with me. i’ve never quite understood when to sudo and when not to, when to gksu and when to gksudo. Seems that my limited experience is that the rules seem pretty inconsistent and vary quite widely among apps. Will give it a go at rebuild and launch later tonight. thanks.

“su” is “super user”.
“sudo” is “super user do …”
“Super User” can trash your machine - use with care.

By default, “users” are not allowed to make changes to the system. Users can “use” the system, but not make changes to the operating system. This makes using a Linux computer relatively safe. However, there are times when it is necessary to make changes to the system, for example, to install new software, or update the system. As a normal user you cannot do that, so you have to call on the service of “Super User”. Super User has the same access as “root”, and “root” is source of all things - “root” is god.

Note that some applications do not need to be installed into the system, but may be run entirely with standard use access. In such cases, elevated privileges are not required, so “Super User” should not be invoked. Only use the power of root when you must make changes to the system.

“gksu” is the same as “su” but with a graphic interface.
“gksudo” is the same as “sudo” but with a graphic interface.
The “gk” part comes from “GTK”, which forms the basis of very many graphical elements in Linux.

If you must run a graphical application with sudo, you should use gksudo instead which should stop ownership problems occurring:


Well, ended up going back to Ubuntu Studio after Mint started not even recognizing my sound card. This seems to be a problem with Mint and Realtek sound cards and had it happen before to me on 17.3 Cinnamon.

With me Mint totally loses my soundcard after installing Pulse Audio.

Anyway, thanks for the info on SU, GKSU, etc. Good to know.

Is there any particular Linux Distro that you guys would endorse or know that works better than others specifically with Audacity? I seem to run into quite a bit more issues on Linux with Audacity than ever did on Mac or Windows. Not exactly sure why but between, freezes and plug-in issues on Ubuntu, this issue on Mint and my previous issues on Debian based I seem to be having some problems getting it as stable as I’d like. I’m going to try it on Arch Antergos, had installed Audacity there but that is having all other sorts of problems with grub-efi now and had to work on it before even got to check out Audacity. So far Debian based has been the best but I haven’t been able to fix the issue there with audio on multiple sources not working. Works great on Audacity but get no sound anywhere else when Audacity in use. So far have been wading thorough the “fixes” online and nothing quite working thus far. For the life of me I also cannot get Jack configured correctly either, but that seems to be a whole other bunch of issues.
Oh Linux, how frustrating it can be some times.

Why are you installing Pulse Audio? It should be installed by default on Mint.

Beware “fixes on-line”. There’s a lot of bad advice out there, especially about sound systems. If you have sound card hardware that is not supported by Linux, then you’re flogging a dead horse trying to get it to work. Having said that, most on-board sound cards work “out of the box” on most modern Linux systems. I currently use Debian Stable, and have previously used Ubuntu and Mint. Like many Ubuntu users I had lots of problems when Ubuntu first used PulseAudio as their default sound system, but in the last 5 years or so every Linux installation I’ve done has been free of sound card problems.

When you installed Mint, did you do a fresh clean default installation? If not, then I’d suggest you try that. Something that caught me out in my early days with Linux was copying the contents of my old Home folder over to a newly installed system, without knowing what I was doing. The Home folder contains many configuration files (usually as hidden files or hidden folders), and copying them over from one system to another (different) system can cause hard to find compatibility problems.

I Should clarify. Reinstalling PulseAudio after purging it while trying to get the Realtek Soundcard to be recognized. Mint 18 out of the box was just showing it as “Dummy Output” and no sound. Seems to be a long going problem that is (now anyways) pretty contained to Mint. It previously affected Ubuntu and Debian from what I see posted online. Only way to even detect it was via VLC Media Player which also showed it as present but under “Dummy Output”. Previously I had been able to get it to work by purging and reinstalling PulseAudio in Mint.

from article:
"By default Linux Kernel/ALSA does not support this chipset correctly. It swaps the rear speakers, the side speakers and the LFE/center speakers as well. In other words, only the front speakers works right.

Using the “automated” realtek official driver installation leaves you to a no-sound and no hardware sound support."

applies to Realtek HD Audio chipset/soundcards:

That should not be the case if you choose the pulse playback device in Audacity. Yes that tends to freeze up, but PortAudio have been working on that Those changes will propagate to Audacity when they become part of PortAudio and we update to the latest PortAudio version.


I have the same issue with my Audacity 2.1.2 on Linux Mint 18.3. I tried to run Audacity as sudo or gksudo, but with no success. I am a Linux noob, I don’t know how to set permissions for Audacity.

You should never, ever run any program as sudo except for when you are doing so to make changes to the operating system.

Which “same issue” are you referring to?

I am referring to the issue described in the first post of this thread.

Why are you building Audacity 2.1.2 from the source code?

I don’t, I use the Audacity which came pre-installed with my Linux Mint. But otherwise my issue is the same as in the first post of this thread.

The original post says that the error message was:

00:06:28: Error: Impossible to get permissions for file '/home/ericmint/.audacity-data/pluginregistry.cfg' (error 2: No such file or directory)

What does your error message say?