Plug-in Enabling Error (ill-formed Nyquist plug-in header)

So, I’m at the end of my rope on this. I’ve looked at other people with the same issue and haven’t found a solution that works.

I’m trying to enable Chris’s Dynamic Compressor on the newest version of Audacity on a Dell tablet. I’ve never run into this problem before, and I’ve tried everything to no effect, including downloading older versions of Audacity for the heck of it (didn’t even get the option to enable plugins that way, so, yeah).

I’m running Audacity 2.3.2 on Windows 10. I’ve put the plugin in the proper folder. I load up Audacity, go to the Add/Remove option, enable the advanced version of the compressor, click OK, and I get the “ill-formed Nyquist” notice. I have no idea how to fix it. I’ve tried downloading, re-downloading, re-installing, restarting, and every permutation therein. Nothing. Same warning. Every time.

If not for the fact that the onboard compressor doesn’t have the settings I need, I’d just use that, but my entire editing process requires this compressor. So…here I am. Asking for help.

I’ve not had issues with other plug-ins, so maybe there is a problem with the new version of Audacity and this plug-in? If so, is there a solution to fix it?

Thanks in advance.

It’s probably a fault in the plug-in. Please attach the plug-in to your reply so that we can look at it. (See:

Hey steve. Thanks for the reply.

Hopefully, I’ve attached these correctly. I included both the advanced and the regular version. I get the error with both. I think the advanced version is the one I need, but I haven’t had to do this since getting this new tablet for work.

Here they are: