PLEASE please please help me- did I lose everything?

I don’t even know how to search for the problem.
I had audacity open, and I was organizing my files in finder. When I went back to audacity, my project had no audio. It has the chunks of audio there, but they are flat lines. The whole 30 minutes are flat lines. I have no idea where the audio went? I tried to open it again and it’s talking about having 500+ orphan files? I don’t know what to do. I don’t understand what happened, so I don’t know how to troubleshoot?

If you are using Audacity 2.2.1, please stop using it and update to Audacity 2.2.2 asap. There is a critical bug in 2.2.1 as described here:

Audacity has an operating technique where it doesn’t make “personal copies” of music you included but instead references them as needed.

This lets Audacity run blistering fast because it doesn’t have the baggage of all that music, but it does have a downside that you can’t ever move the music around the filesystem. For example, if you used a fragment of “Battle Hymn of the Republic” in your piece and then move the music file somewhere else, that fragment will turn into a flat line. The only solution other than re-editing the piece is put the music back where it was.

The Phrase That Pays is someone posts: “I cleaned up and my project fell apart.”

Audacity used to default to running that way and it caused tons of problems. I’ll find the setting in a minute.


Here it is.

Audacity > Preferences > Import/Export: [X]Copy … Files.


That’s the source of your problem. The AUP file and its associated _data folder must be in the same directory (folder) and must not be renamed.

it’s talking about having 500+ orphan files

Choose the “close immediately” option.
Find the AUP file and drag and drop it onto TextEdit. Near the top you will see a line that looks like this:

<project xmlns="" projname="MyProject_data"

where “MyProject” will be the name of your project.
Close the file in TextEdit without saving changes.
If the AUP file does not have the same name as what comes after “projname=”, rename the AUP file to have that name (without the “_data” on the end).
Find the _data folder that went with the AUP file. Try to remember if you renamed or moved it. If the name of the folder is not exactly the same as what comes after “projname=”, rename it to that (including the _data on the end).
If necessary, move the AUP file and the _data folder into the same folder.
Now try to open the AUP project file. If you still get errors, come back here and tell us what they are.
Also, please read this page in the manual.
– Bill