Please help... tears have been shed

I have used Audacity since 2008 with NO ISSUES.

Today (when I have a VO that is past due. One of this situations where EVERYTHING has gone wrong.) I am hearing an echo in my headset. I listen while I record, so that I can catch errors better and at this point, I’m at pick-ups so I REALLY NEED TO HEAR MYSELF.
Here is what I have
Sennheiser MK4 microphone
Sennhesier 280 pro headsets
Focusrite 2i2 2nd gen interface

I have googled every possible solution and I have spent well over EIGHT HOURS trying to solve this problem. I have switched microphones, interfaces, and computers. NOTHING WORKS. (So please, please, please do not suggest that I uncheck listen through this device, nor playback sound through in preferences)

Then I tried the built in recorder in my laptop from Windows - NO ECHO. It’s audacity.

If anyone knows something that will help, I would appreciate it. Though at this point, I’m switching to Pre-Sonus or ProTools first just to get this done. It has taken everything in my not to fill this post with curse words. I LOVE audacity, but right now I HATE IT.

We have to be nit-picky about this to figure it out. You do not have Sennhesier 280 pro headsets. You have Sennheiser 280 pro headphones. Good choice.

You have them plugged into the 2i2 headphone connection with it’s gold big to little adapter, right?

I can’t tell from the 2i2 instructions. Does the Direct Monitor button have three positions?



The Direct Monitor only has two - off and on.

I also have the latest version of Audacity, 2.4.2. I downloaded recently and thought that was the problem. But then I uninstalled and went back to 2.3.x and it still happened.

Then I uninstalled and reset preference (I actually completely wiped my computer at one point. That was a fun 2.5 hour wait) and it worked for a quick second. I took a break to eat and came back and it was echoing again. That’s when I just started crying. I was at this from midnight to 7am last night. I am so over this.

The Direct Monitor only has two - off and on.

The instructions insist you can switch between mono (one circle) and stereo (two circles) lit up. You can’t both be right. We need this settled because that’s what’s driving your headphones.


Here is a clear picture of the front. I have the 2nd generation. You might be looking at the third.

I also did the latency test. Got it to match PERFECTLY at -92. Recorded - still an echo.

I also didn’t see the two arrows that they were speaking of at the end of the instructions.

I took a break to eat and came back and it was echoing again.

That’s super good to know. Do you use Skype, Zoom or other conference, communications, or chat apps? Do you leave them running in the background while you work? Do you launch them fresh each time? Do they launch themselves each time?


Nope. It’s a windows laptop (I broke my macbook) and it’s pretty much only VO. It stays in the studio.

Now audacity isn’t recording at all. It’s just making the tool bar icon shake and the recorder won’t move.

I am done…

I have the 2nd generation.

Also good to know. Changing instructions.


I am done…

You shouldn’t get too far ahead of us. We have to build your system in our heads to figure out what’s happening.


If you use teamview and want to connect, please feel free.

I see what happened. The new one has a pushbutton and goes through different adjustments and states. The older 2i2 has a simple flip switch.

Flip Monitor ON. Close Audacity. You should be able to listen to yourself clearly and correctly—once.


teamview and want to connect, please feel free.

I might enjoy that, but you wouldn’t. My download speed is OK, but my upload speed…isn’t.


Do you have more than one USB cable that fits between the 2i2 and the computer? Does the computer have more than one place to plug it in?

What happened to the poor Mac? The last time my 2009 MacBook Pro recorded sound—correctly—was yesterday.


Hi there! Thank you! Sorry, I just had to walk away for a second. This is really upsetting. I need to finish this recording - but I am going to return to the site. I just want you to know that I genuinely appreciate your willingness to help. At this point, I’m just going to play “guess the tone” and hope for the best. I need to get this done tonight. It’s 2am and I still have about 3 hours to go.

Thank you!!!

I didn’t understand the close audacity part… I’m recording a voice over for a client - an education course. I need audacity to record it. Unless there is a way I can record closed???

I only have one, but I have tried 3.

lol, a smiles - this was three years ago, when I used to record in the kitchen of my apartment. I made a noise complaint (it was ridiculous) and the security guard came over and after he addressed it, he started chatting politely about VO and stuff in the community. After 30 minutes of chatting I was kinda ready for him to leave - I think he was bored driving around in his car.

Anyway, I didn’t know how to politely say it, so I started cleaning so my time wasn’t completely wasted, but mentally stressed thinking of the things I needed to do if he would LEAVE. I didn’t pay attention. I was going to wipe off my desk and instead of wringing the towel out over desk, I did it over the macbook. Basically two-cups of hot soapy water directly in the keys. And even after I gave a small little scream after realizing what I did, he STILL wouldn’t leave and kept talking.

I’m switching to Pre-Sonus or ProTools first just to get this done.

That’s how you’re getting the current jobs out the door. We are trying to figure out why your Audacity is failing for the next job.

You have a collection of super odd symptoms. I’m trying to sort through it. One technique I’ve found useful is take the problems upside down. If somebody paid me to make your computer do this, how would I do it.

Shivering or lurching Audacity usually means the connection between Audacity and the 2i2 is bad or failing. I’ve never had a USB cable actually fail, I have had a bad connection where I didn’t get the cable plugged all the way in. I’ve also had problems where I was accidentally moving a cable while the computer was trying to use it. That didn’t go well.

I can’t account for echoes that happen by themselves. That’s the sort of thing that can be caused by something other than Audacity “helping you out.”

Can you try a different computer? Even if you’re not performing in your studio, Audacity is free and if your echo and shivering Audacity vanishes, that’s good to know.


Unless there is a way I can record closed???

No, but it’s a respected troubleshooting technique to divide the system in portions and make sure each portion runs right on its own.