Please help me

I hope someone can help me. I need a older version of Audacity, the version before this latest update.
I do not know the version that I was using, my stupid self never checked. I know it was the update before
they brought out the new sliding marker with this current update. I believe it was the update before 3.1.

I can not use the current update of Audacity due to me being blind in one eye and the current update is
bothering my eye and head. I have tried to use other sites to take Audacity’s place but nothing can compair
to audacity. Please help me

I forgot to add that i am using macos sierra 10.12.6. Sorry.

Previous versions of Audacity are available at https://www.fosshub.com/Audacity-old.html
– Bill