Please disregard previous thread

Howdy folks. I encountered a problem: I am wondering if I somehow screwed up my turntable needle. When I record I get no music waveform, then a pound SCREECHING comes and goes. I aim using my built in microphone (mac desktop) & had no trouble whatsoever recording last two albums. Does anyone have any possible fix or wisdom?
Thanks much.

Hello. Just a beginner.
I am using OS X 10.11.3, built in microphone, & a Pyle PLTTB3U turntable. I have tried to set the input level for -9 (did THAT) under preferences, however,my meter shows only -30 to -37. I read -9 was the optimum choice. However, during recording I am getting different level. I have tried to manually drag the cursor to the desired level but it doesn’t work!Am I wrong in some way? Am I mistaken in the -9 db range? Or, is it my mac?
i have read & read and still dp not find away to record at desired level.
Thanks for any help. I have read the manual, but it doesn’t answer this problem I have.


Hi again folks!
Please disregard my previous thread. I found the “fix” for the input audio topic. \Just took a LOT of playing around before I was able to resolve the problem.

Please, my apologies…


I presume that all these posts are about the same issue, so I’ve merged them into one topic.
Generally it is helpful to stick with one forum topic until the issue is resolved and only start a new topic if it is about a new, unrelated issue.

OK, thanks for letting us know. I’ll close this topic now.

If you still have problems please start a new topic as Steve suggests.

I hope you are recording from the USB Audio CODEC or similarly named recording device in Device Toolbar. If you are choosing the built-in microphone to record from, you will get terrible results.