playback with only weird sound

I am using Window 8 with notebook. When i record, there is no blue wave. When I stop recording, the blue wave comes out. However, when i press playback, it only comes out very annoying sound but not the thinga i have record.

Besides, it can insert MP3 music but cannot be played. When i choose window WASAPI, MP3 can be played but it can only record with the notebook mic. I cannot choose using my own usb mic.

What can i do? try different ways but still fails…

thanks millions!!!

You will need to quit Audacity, enable all the recording and playback devices you may ever want to use in Windows Sound and then restart Audacity and choose the playback and recording device you want to use now in Device Toolbar.

You may also want to turn off recording and playback enhancements in Windows.

Click the blue links in the text above to find out more.


Thanks a lot Gale!

I tried the things you mentioned above but still fails to record. Another problem is that even when I insert MP3 track, it comes out sound like when you cannot connect well with the radio. is there anything wrong?

I took my notebook to the check too and the staff said my notebook is fine with the recording as I can use the internal window 8 recording function.

thanks again with your help!

Is it the USB mic that fails to record? If so, you have to get Windows to see it first. See the green box “Detecting USB and Firewire devices” here:

When Windows recognises the USB mic, choose it in Audacity’s Device Toolbar. If the mic is not listed in Audacity’s Device Toolbar, try Transport > Rescan Audio Devices. If the mic errors or records a flat line, try choosing “1 (Mono) Recording Channel” in Device Toolbar.

If the recorded level is too low, use the mic slider in Mixer Toolbar to turn up the level:

If you need more help, please state the make and model number of the mic. Tell us the exact symptoms when the USB mic fails to record. What you wrote:

When i record, there is no blue wave. When I stop recording, the blue wave comes out.

doesn’t make much sense. Sometimes you can record, you see the blue waves, but then the waves disappear when you stop recording.

Do you mean when you import an MP3 into Audacity and just play it? Or are you recording something while playing the MP3 track?

As I said, you should turn off all playback and recording enhancements. You may even have to go into your sound card’s own control panel and turn the effects off.

If you are recording something while playing a track in Audacity, turn off Transport > Software Playthrough in the Audacity menu bar.