Playback Sound HELP

So I finally got everything working, but when listening to the saved file, the sound is almost as if I was using a phone to record it and not from my laptop. You can hear my TV in the back round.

You have recorded using the laptop’s built in microphone.

To record sounds that are playing on the computer, see:

Assuming that you are using Windows Vista or later, scroll down that page to the section: “On Windows Vista, Windows 7 or Windows 8 only …

Ok. Thank you. But now it’s saying error while opening sound device. Please check device and settings. What do I need to adjust?

Have already been recording and have not changed any settings but getting an error message now for divorce settings or project sample rate. Any ideas?

No idea at all until you tell us:

  • which version of Windows you are using,
  • the exact three-section version of Audacity (from Help > About Audacity)
  • the exact error message.

Sorry. I’m using windows 8. And by 3 section I’m going to assume you mean windows direct sound, speaker/ headphones and primary sound capture?

Also, the message says "error while opening sound device. Please check the recording device settings and the project sample rate.


It means that Audacity is unable to access the audio device that is selected for recording.
What are you trying to record, and what is selected in the device toolbar?

The “three section version of Audacity” is, for example: Audacity 1.2.6, or 1.3.4, or 2.0.1, or 2.0.6
If you look in “Help > About Audacity” you will see that the three part version number is clearly displayed.

There is a detailed FAQ for this:


Please don’t post multiple topics about the same problem because then we have to reference each topic to find out your system details and guess what you are trying to do. I merged the topics.

Which version of Audacity are you using?

Quit Audacity and open Windows “Sound” ( Missing features - Audacity Support ) and follow the instructions in the link to show and enable all your audio devices.

Are you using Windows WASAPI host in Device Toolbar to record computer playback? If so, try choosing 44100 Hz project rate bottom left of Audacity.


Sorry it’s 2.0.6

And I tried putting it on windows direct and wasap and both still don’t work. And I’m using a USB turntable.

Do we assume you can still record the USB turntable OK, and that the error occurs when you try to record audio playing on your computer? What is that audio you want to record? Is it a YouTube video?

Did you go into Windows Sound and enable all your devices Missing features - Audacity Support ? You have to enable your playback devices too, or you won’t be able to play audio.


It only allows me to record when I put it on internal mic. And I’m trying to record a mixtape. Playing off my serato dj software. And sorry, but I can’t locate the “record” tab to right click.

What hardware are you using? If you bought a cheap controller without a Serato licence key then you can record with Serato if you buy a licence. It may be easier for you than setting up Windows. See Recording Your Set with Serato DJ.

Does your computer have a blue line-in input as well as mic input? If so you can record into the line-in rather than record computer playback. See the above Serato article.

To access Windows Sound, look for the speaker icon by the system clock. Here it is, with a red border around it so you can recognise it:
Right-click over that speaker icon, then choose “Recording Devices”. Then right-click anywhere inside the Recording tab and choose “Show disabled devices” then right-click again and check “Show Disconnected Devices”. Then right-click over each device that you see in the window, and choose “Enable”.

Then click the “Playback” tab and do the same - show disabled and disconnected devices then enable each device by right-clicking over it. OK all the dialogues then restart Audacity.

If you now have a stereo mix recording device in Audacity’s Device Toolbar, try choosing that then play your mix with Serato configured to play to your built-in sound device.

Or, with Serato configured to play to your built-in sound device, choose Windows WASAPI host, playback device is your built-in sound device, recording device is your built in sound device (loopback).


Thank you the help. I have followed all steps. Only, once attempting to right click and hit “enable” it only has the “disable” option. After doing what you said, i still have the error message. And I have a serato licensed mixer. But my software doesn’t have the record option. I have dj intro.

In that case, that playback or recording device is already enabled.

You could upgrade the software. I think you may have to spend money, either on serato software or perhaps paying a computer technician to come to your house and help you.

How exactly are you attempting to record your mix? Are you connecting cables from your mixer to the computer or are you trying to record what you hear from the Serato software? If you are recording what you hear, can you actually hear what you want to record?

Did you find stereo mix in Windows Sound or are you trying to use Windows WASAPI?

If you need more help, I suggest you show us your audio devices. In Audacity, open Help > Audio Device Info… . In the window that opens, right-click then Select All. Then right-click and Copy. Paste that information here.