Playback jumps with Steinberg UR22 interface [SOLVED]

I have a Steinberg UR22 interface that I use with a Macbook Pro running OSX 10.6.8. The UR22 works fine with all my other audio software on this machine (Reaper, Izotope RX3 Advanced, Audio Hijack Pro, Quick Time, iTunes, core audio…) However, when I try using audacity with the UR22 interface, the playback constantly glitches and jumps, making it unusable. This happened with Audacity 2.1.0. I just upgraded to Audacity 2.1.2 and the problem is still there. Audacity works fine with the built-in sound on this computer. I contacted Steinberg and they said that, since their interface works fine with all other audio programs on my machine, the problem must lie with Audacity. Any suggestions?

Please try reducing “Audio to buffer”:

Also ensure the Audacity project rate bottom left and the rate of existing tracks matches with the sample rate chosen for UR22 in /Applications/Utilties/Audio MIDI Setup.


Thank you Gale for your quick response. Your suggestion to reduce the Audio Buffer setting in preferences solved the problem.