Playback is fast and skipping

Just downloaded Audacity 2.1.2 after uninstalling (to the best of my ability) an earlier version. Want to record audiobooks using an Apogee mic. The playback on my Macbook Pro with El Capitan is unusually fast and breaks up. I attempted to uninstall and reinstalled, but there was no change. Did I make a change inadvertently in some setting? Playback speed is set at 1.00. I’m hoping you can give me some ideas on how I can resolve this.

Shut down the Mac. Unplug the microphone. Start. Listen for the opening Chong.

Run Audacity and reset the recording to the built-in microphone with the device toolbar (opposite the microphone symbol).

Mine says Built-In Microphone and 1 (Mono) in the next window to the right.

Press record and read the side of the milk carton or cereal box. The Audacity sound meters should bounce with your voice. You may need to turn the MBP speakers down. Stop. Play it.

Does it come out correct?


What audio device are you using for playback?

You may want to reduce “Audio to buffer” in Recording Preferences:


Tried the suggestions to no avail. It seems to be recording off of the internal mic, but skips and then won’t record at all with my Apogee mic. Playing back on my MacBook Pro speakers. Getting this latency problem message once it freezes.
Screen Shot 2016-02-19 at 11.24.02 AM.png

Also tried playing with the buffering to not avail. Sending the file so you can see what’s happening.

It seems to be recording off of the internal mic, but skips and then won’t record at all with my Apogee mic.

That’s important because it means the Mac internal systems are all working and the problem is most likely with the microphone, cables or the microphone connection system.

Is there a microphone model number?
This one?


I think we found the problem… it looks like some of the files may have been left in the library from a previous uninstall. We cleaned it up and reinstalled fresh and it seemed to do the trick (at least for now.) I don’t think it was recognizing the Apogee mic since it hadn’t been showing up in the dropdown menu until we deleted the files. THANK YOU so much :slight_smile: I appreciate having places and people to bounce things off of!

Assuming it uses the lightning port, then if you connect it after Audacity is open you will have to use Transport > Rescan Audio Devices in the Audacity menu bar.


Hello again. I am having success with recording and playback at the moment, but received this pop up earlier. Does this give you any new info? (btw, it doesn’t use a lightning port. Also, the Apogee Mic doesn’t have a model number - It’s a "professional microphone for iPhone, iPad & Mac.')
Screen Shot 2016-02-20 at 11.21.25 AM.png

Then where do you connect it to the Mac exactly?

One reason you might receive error opening recording device is if it’s a USB/Firewire/lightning device and you disconnect and reconnect the device while Audacity is open.


Apple’s creative naming schemes… :smiley:

There is no Lightning port on Macs. That’s an iOS (iphone, ipad) thingy. On Macs, it’s called a Thunderbolt port. No wonder it confuses most people…

And Apogee is in the same club. No type number. It’s THE Apogee mic, as there is only one. Apogee doesn’t manufacture mics.

This sounds like a typical USB dropout. Could Antiplop save the day? Does that still work on El Capital?

Have you tried counting to 100 before typing that? :bulb:


Thanks Gale! So the solution, in that case, is to shut down Audacity, and restart with mic already connected? That would sure be a clear and easy fix.

Thanks Cyrano, for clearing that up!

What is “Antiplop” and should I employ it? I do have El Capitan.

Thanks so much!

Do you have a portable Mac?

If yes, maybe it could help. If no, forget it.

Antipop is a smart workaround that’s well hidden on the net. Gale found it.

It “plays” a synthetic voice in the background, speaking a “space” every ten seconds or so. Of course, a space isn’t audible, but doing that will keep your Macbook’s audio system awake.

It seems that Apple, in its never ending search for better battery life, puts the audio system to sleep to soon. And Audacity can’t keep it awake sometimes. Running Antipop keeps it awake, that’s all. And that’s also why iMacs and Mini’s are not affected as they have no battery. See:

I’ve been running it on Mavericks for a couple of days now and it’s prevented Audacity from loosing connection to my audio interface from time to time. I don’t know how it runs on El Capitan, but there’s an uninstaller included, so testing it shouldn’t be a problem.

And it’s Antipop, not Antiplop. My memory’s full, apparently… :confused:

You don’t need to restart Audacity. You can use Transport > Rescan Audio Devices instead.