Playback is failing with multiple tracks

Hey!

I am having trouble with playback after I have recorded more than 3 layers of tracks. It will go completely silent with sometimes faint pops and cracks as soon as a forth track starts but only if all 4 tracks are “at the same time”. Also, when I record layers of tracks it seems the audioquality of the playback is immediate lowered drastically. It feels like there might be a connection with that.

Maybe this is a simple problem and I might have missed something basic since I am a new user and don’t have any experience at all with this stuff before. I have tried searching for this in the forums with no luck.

I have tried to fidget with playback and deleting effects manualy from the soundcardsetting and bitrate and whatnot and no I have run out of stuff to try.

I use a very basic USB microphone with generic usb driver software.
Windows 7
Audacity 2.0.4 .zip
Realtek high definition audio from onboard MSI mothercard. (when in my device manager I also see 4 NVIDIA high definition audio devices)

Thanks in advance!

I haven’t used multiple tracks with Audacity… I have no idea why it’s going silent…

What kinds of effects are you using? Any 3rd-party effects that might not be 100% compatible with Audacity?

The “sound quality” issue is probably your clipping (distortion) of your digital-to-analog converter (soundcard). Mixing is done by summation. The volume increases when mixing and and the mixed signal might be "trying to go over 0dB (the digital maximum).* Many effects will also boost the level. You may have to lower the volume of each track before mixing. When combining 2 tracks, lower the volume of each track by 6dB (half). With 3 tracks, lower the volume by 9 or 10dB (1/3rd), and -12dB (1/4th) with 4 tracks.

Simply lowering Audacity’s “Output Volume” might take care of the playback/monitoring distortion. But when you render (Export), you should keep the peaks below 0dB.

Pros usually record at around -18dB (with a good low-noise 24-bit/96 kHz interface). Then, they use the master volume control in their software to get a good level, regardless of the number of tracks.

After mixing, you can use the Amplify effect to bring the peaks of your combined file back-up to 0dB if necessary.


\

  • Audacity itself (like most audio software) uses floating-point so there is no limit at 0dB. However, you can clip ADC (analog-to-digital converter) during recording, your DAC (digital to analog converter) during playback, and regular WAV files (and CDs, etc.) are also limited to 0dB.

I’m betting your computer isn’t powerful enough to play back that many tracks at once. One real time playback stresses the computer and the stress goes way up when you have multiple tracks. If you are trying to overdub live performances against recorded ones, that’s much worse.

Live audio is not like spreadsheets or calculating blur in Photoshop. The computer can’t blow a whistle and stop everything while it works – although in your case, it sounds like it’s trying.

Koz

You may find this article helpful: http://wiki.audacityteam.org/wiki/Managing_Computer_Resources_and_Drivers

A computer is not a ready-made recording studio

I’m buying the author of that line coffee – or a cuppa, depending.

Koz

Cuppa please, then.


Gale

Whoa, a lot of suggestions here.

I get the feeling that the dac, explanation is most probable.

I’ve got a quadcore AMD Athlon II x4 640 Processor on 3.0ghz
4gb ram
motherboard: msi gf615m-p33

Shouldnt that be enough powerwise except that the on board soundcard might be crap?

I am also playing all this through an amp and speakers. Is there any setting that might be wrong to specify that I am not using active speakers or anything?

What kinds of effects are you using? Any 3rd-party effects that might not be 100% compatible with Audacity?

None that I know of, I have turned of the effects or “enhancements” manually in the mixer. My playback is set to, Speakers (Realtek High Definition).

I am recording mono. I should ad that whenever I try to boot the volume on one track to much on playback after recording (I do not do live overdubs) it also goes completely silent, this can happen with less than 4 tracks simultaneously. It also seams that when I do have my output level meter on it looks completely maxed out, no matter what the level I put on output volume.

I also see that I have put my input volume on 0.75, it that to high?

All of the sound, gets recorded “above the black line” a roughly 0,4 in the far left scale in every track.

Oh, and i record at 16-bit pcm.

Doing the whole manual db changes, sounds like a right hassle. Since I am not a pro I would like to hear what I have recorded before when I record the new stuff and I do a lot of retakes as well. And does this meen that the project I have now, although not very long, has to be remade?

I am thinking of trying that LatencyMon but will probably need help interpreting the data.

I’m using a cheap 2 GHz dual core Intel Acer laptop (with Linux) and I can record 40 tracks before the sound starts to lag. If I push that up to 80 tracks, then there is a delay of several seconds before playback starts, and as it plays some tracks will drop out and stop playing - my computer does not like this so I’m not going to push it further, but I’d guess that if I left it running the sound would stop altogether. I expect that my Linux (Debian) operating system is somewhat more efficient than Windows 7, but I don’t think that should account for a ten fold performance increase.

I record as 32 bit float (the Audacity default). Modern computers can often handle 32 bit float a bit quicker than 16 bit data, mostly due to built-in floating point processors. However, the amount of data being pushed to and from the hard drive will be double at 32 bit compared with 16 bit. If there is a bottleneck with hard drive throughput (input/output) then 16 bit can work better. However, on a modern computer the hard drive should be able to handle a lot of track at 32 bit.

Anti-virus programs can create a problem here. If they are checking each block of data before it is written to disk, then that will cause a serious bottleneck.

If Windows is updating, or some other maintenance task is thrashing the hard drive, then that can also radically reduce the computer’s ability to read / write data from / to the hard drive.


Sound card drivers can make a huge difference.
As your sound card is built into the motherboard, check on the MSI website that you have the latest available drivers for your motherboard and Windows 7.

That sounds weird. What’s that about? I’d suggest looking into that.

Is the amp plugged into the on-board sound card “line out”, or connected some other way?

Cuppa please, then.

[writing that down.]