Playback devices disabled


I launched Audacity to try to record myself. I had a set of earphone/mic from a cellphone plugged in the only jack port my pc have (an ASUS G551JM, win 8.1 ).
I could record myself with the mic, but I couldn’t hear anything in the earphone. And audacity was only picking up “Realtek HD sound manager” as both record and playback device.
When I unplug the earphone, the PC speakers work just fine.

Even worse, now, every single headset that I tried are no longer working, on any applications.
I rebooted several times (wich usually solve the bug, but not this time…), I reinstalled the realtek drivers (and rebooted of course), I uninstalled Audacity.

Finally, the realtek sound manager detect when I plug the earphone and ask me to choose between earphones/micheadset/speakers, but none of theses change anything.

So please advise! Thank you.

By the way, I was using Audacity 2.1.0

Sooo, I basically tried everything. I even tried remapping the jack port with regedit, with no success. Worse, the values were rights.

Then I tried to basically turn off completely the PC, then turn on again.
The problem disappeared.


But I think that it would be good that this bug (which has also been spotted by ubuntu users), could be solved in the end.


The current version is 2.1.2 which you can get from the Audacity website here:

It’s probably not an “Audacity” bug.

There is a “limitation” in Audacity that Audacity only looks for audio devices when the program is first launched, and only looks again if you “Transport menu > Rescan Audio Devices”. Re-scanning the audio devices can take several seconds (depending on the system) and Audacity is inoperable while it is doing it, so it could be very disruptive if Audacity re-scanned without being told to do so.

If Audacity is unable to see a device that has been connected before Audacity is launched, then check in the Windows Sound Control Panel to see if the device is enabled. If the device is not enabled by the operating system, then Audacity will not be able to see or use it.

Generally, Audacity “should” be able to immediately see headphones that you connect to a built-in audio port while Audacity is running, but it definitely does not always work, and I would not jump to the conclusion that it is an Audacity problem.

If the built-in device was disabled previously you will need to rescan in Audacity.

There seems to be another “ROG” G551 JM which does have separate audio in and out ports. :confused: Anyway are you sure you have the latest Windows 8.1 audio drivers from the ASUS site? If you don’t, you could receive problems.

Also note that the Windows 8 and later “Shut down” defaults to a “hybrid boot” that retains the kernel session in memory, so producing a “Fast Startup”. When you want to replenish resources you should do a traditional “cold boot” (full shutdown) instead. On Windows 8.1 you can do that by explicitly using “Shut down” from the Win + X menu.