Play function frozen

Win7 Pro system, Audacity v2.1.0

While I was fiddling with an mp3, all of a sudden the app ceased to recognize the green arrow play button. I tried clicking any obvious button or link to no avail. it will not play the file. The system appended a little space in front of the beginning of the file. I move the tracker bar anywhere in the file – no workee. i must have hit some sort of switch, where is it? I tried different wav and mp3 files. No dice. I uninstalled and redownloaded and reinstalled Audacity from sourceforge. Still frozen. This is bizarre – what in the world happened? I’ve used Audacity on and off for years and never run into this problem before.

The main point to note is that SourceForge is no longer our download site. The current Audacity release is 2.1.2 which you can obtain from our site http://audacityteam.org/download/windows.

When you install 2.1.2, look for the “Select Additional Tasks” screen, and in that screen, put a check (tick) in the “Reset Preferences” box. Complete the installation. On launching Audacity, a dialogue will appear where you can confirm if you want to reset preferences just this once, or not. Agree to the reset.

This should hopefully restore normal behaviour.


Gale

Thanks for the tips. I downloaded 2.1.2 which seems to function just fine.

After writing the plea above last night, I continued to try to figure out the problem, and discovered that not even youtube vids would play, nor VLC movies. Bizarre. Then somehow the freeze resolved itself. So it was not just confined to Audacity though that’s where I first noticed it. I have no idea what to do besides wait it out if this happens again. Computers and apps are both godsend and nightmare, arbitrarily at their own discretion.

Assuming you are using the built-in sound card for playback, it is possible it does not have correct drivers. See Updating Sound Device Drivers.

Also have you done a thorough anti-virus check recently?


Gale