PLAY button

I’ve been using Audacity 1.2.6 (on XP) happily for years and I only found out about 2.0.2 just now. Upon installing, I’ve noticed that when you PLAY, STOP, then PLAY again, it starts from the point it stopped, not from the point it initially started as in 1.2.6. It’s really frustrating as I’m a translator and I need to hear the same parts again and again, so this feature in 1.2.6 was just perfect. Probably there is an option to set this in 2.0.2 but I’m unable to find it. Could anybody help me please? Thanks in advance!

My copy of v2.0.2 does what you want yours to do. I’m running on Windows 7. So is this an operating system “thing”?

That is not the default behaviour.

The default behaviour is that stop returns the cursor to the original "play from position.
Note that in Audacity 2.0.2 there are two alternative layouts of the transport buttons: (see “Ergonomic order of audio I/O buttons” )

If you are using keyboard shortcuts and you are getting the wrong behaviour, you may need to reset the key bindings:

With the default behaviour:
To stop playback and return the cursor to the original playback position, press the Stop button or spacebar.
To stop playback and leave the cursor at the position that play had reached you can either press Pause (or the “P” key), or shift+A (stop and move cursor to the position that play had reached).

There are other alternatives that you may like to try:

Click on the waveform to set the playback position.
Press spacebar to start play,
press P to pause or spacebar to stop or shift+A to stop and reposition the playback position.
Click somewhere else on the waveform to set a new “play from” position.

While stopped:
use the left/right cursor keys to move the “play from” position,
or the comma/period (full stop) buttons to jump 1 second at a time left or right,
or the < and > (shift + , or . ) to jump 15 seconds left or right.

Select a region to playback (click and drag on the waveform)
Press shift + spacebar to “loop play” the region.
press P to pause.
press P to continue looping playback of the selected region.
press spacebar to stop or shift+A to stop and reposition the playback position.

Click on the timeline at the top to immediately playback from wherever you click.

If you want the spacebar to stop playback and move the cursor to where play had reached:
Use the Keyboar Preferences to swap the shortcuts for “Start / Stop” (spacebar default) with “Play/Stop and set cursor” (shift+A by default). You will find those shortcuts in the “Command” section of Keyboar Preferences.

Are you sure you’re pressing the Stop button and not the Pause - that sounds like Pause button behaviour.