Pinnacle pre-amp

I have a Pinnacle pre-amp that I used in older versions of Audacity with good success. It was supplied as part of “Clean” to use as a RIAA preamp.
I cannot get it to work in Audacity 2.3.0 as I can only get a mono recording on both R & L channels. If I use the mic input of my PC it records very distorted audio. Any suggestions as how to get around this please?

Which version of Windows?

Assuming a fairly recent version, look in the Windows Sound Control Panel and check that the “Recording” device is set to record “2 channels stereo”, then look in the device toolbar and ensure that Audacity is also set to record 2 channel stereo.

that I used in older versions of Audacity with good success.

With the same computer you’re using now?

I have a Pinnacle pre-amp

Is that just an analog preamp or does it have an analog-to-digital converter with USB?

If it’s analog, are you connected to line-in on your soundcard? Do you have a desktop/tower computer with a regular soundcard and line-in? (The microphone input is not correct, and it’s often mono.)

I had to install a new HDD in my laptop. As I mentioned, it was an older Audacity that I used and successfully recorded about 200 LPs and tapes, cleaning up the hiss etc.
A new Windows Codec was loaded automatically when I plugged in the pre-amp. This seems to give mono only. I can’t get to the old drivers and codecs. The previous set-up worked perfectly.
I have done all suggestions on replies and thank you for those. Still nothing. Their is an A2D converter. The pre-amp output to monitor just overloads the computer inputs but works well through Hi-Fi.

What model number is the Pinnacle?
Which version of Windows?
Does the Pinnacle officially support your version of Windows?
Did you check the number of channels set for the device in the Windows Sound Control Panel?

Thanks for all the suggestions. I have solved the problem. I uninstalled Audacity and downloaded a previous version that used to work. It worked. I then reinstalled the latest version and, hey presto it worked. A glitch in the first install must have caused it.