piano sounds great going in, lousy in Audacity

Hey Trebor – thanks for the input. Yeah----Bruce got everything he knows from me. (I’m a huge fan).

Audacity has frequency analysis: “Analyze” menu, “plot spectrum”, showing you the frequencies which are present.

Audacity doesn’t Superimpose the two frequency spectra like I did here, I did that using GIMP.

OK, well that’s one problem right there. Channel 1 should be panned hard left and channel 2 hard right. Keyboard Left should be in Channel 1.That will put a stereo show into the mixer when you advance the faders. The GTR/Line switch should be in Line.

The Phantom Power button should be off unless you need it for a very specific reason.

When you record, do you get both bouncing red light metres and a two blue waves? Do the two meters match exactly now?

http://kozco.com/tech/audacity/Audacity1_record.jpg

Your red meters may not look like that.

Koz

Yes, I used “Calf reverb” - I think the “Calf” LADSPA effects are currently only available for Linux, but there are other reverbs available for other platforms. The main objective was to restore some “width” to the sound.

As koz has indicated, the lack of “width” in the recording is because you have both the left and right channels of the keyboard panned to the middle and effectively turned it into mono.

The main tools that I used are on the sides of my head. I then used the “Spectrum View” to go looking for what I was hearing. To see the track as a spectrum, click on the track name and from the drop down menu select “Spectrum”. The resolution and contrast of the spectrum can be adjusted by tweaking its settings which are in:
Edit menu > Preferences > Spectrograms.

For deciding which high frequencies to boost, I took a similar approach to Trebor - there’s no point trying to boost something that’s not there, so forget about boosting really high frequencies because there aren’t any. I’ve got pretty good frequency recognition, but not good enough to say “that’s exactly 16540Hz”, I’d just know that it’s somewhere around 16k - but the Frequency Analysis window and the Spectrum view can help to pinpoint frequencies pretty accurately.

I think Koz has covered everything else.
How about posting a new stereo recording so we can hear what a Roland KF-90 piano really sounds like :wink:

Hey guys – you all have been really helpful. I’ll get back to the keyboard early next week to record a new sample with panning, etc. I’ll post it hear for you. Thanks again!

So a keyboard is a low-impedance instrument and a guitar is high? Thanks again.



Irish recently pointed out this freebee reverb which is rather good.

Compared with a standard microphone input, both are high impedance. The guitar input is probably higher impedance than the line input. You can usually use a guitar in a line input or vice versa without too much problem, but if you have the option to choose you should usually use the guitar input for guitars and the line input for line level devices. Keyboard outputs are usually around line level. Some guitars that have active pickups may work better into a line level input. The really important thing is that if you plug a passive guitar pickup (or other instrument) into a microphone (low impedance) input it is likely to sound really thin and if you plug a line level instrument into a microphone input it will probably distort badly because the signal level is much too high (and could cause damage).

I think I found something that might be contributing to the problem: I put in the cables out from the keyboard into channel 1 and 2 on the board – one at a time (isolating each channel by itself). With each channel, I got sound (the “clip” light illuminated, so I knew I was getting a signal.). However, in Audacity – only the left meter shows activity – the right shows nothing. It’s like it’s forcing the signal into mono.

P.S. That’s also with the left and right pans panned out.

Are you using Audacity 1.3.11 (recommended)?
If you are, go to “Edit menu > Preferences > Devices” and ensure that “Channels” is set to “2 (stereo)”

<<<I got sound (the “clip” light illuminated, so I knew I was getting a signal.)>>>

That’s a valid diagnostic test, but you didn’t leave them on, did you? During the show, those lights tell you the amplifier channel is turning your show into popcorn.

Koz

Hey Steve – I’m using the Beta 1.3 version. I tried going into Preferences, and when the USB cable is being used (from the mixer to the laptop), I choose it for “Playback” and “Recording.” However, it seems to force the sound into mono.

Hey Koz. Didn’t leave them on. Only did it to check the signal.

Aside from any nuts and bolts type issues that have been discussed, here are a few other things I think are worth mentioning.

Your headphone signal is different from your monitors in a couple important ways. Firstly, it exists without entering the air. This means that any phase cancellation issues are going to be entirely different in the cans. Your headphones also are going to sound more ‘direct’ in general than your monitors.

Right and left channels of piano are rarely “true stereo”. You may find that one channel tends to give you a more appropriate tone for your mix.

But in my opinion, one of the most critical things to keep in mind is that the piano has a very broad spectrum. Your mix, with all its cool drums, bass, etc, probably doesn’t really need the full range of the piano. In fact, as those low and low-mid frequencies build up, it is quite likely that the piano will seem dull. Instead of boosting the top of the piano, I would suggest cutting the bottom. You probably don’t need anything below 80-100Hz (roughly). The buildup in the 300Hz range will also tend to obscure the brightness of the instrument. A broad notch of a few dB thereabouts can do a lot to make this better.

Although not directly relevant to your dilemma, there are a few articles on recording (acoustic) piano on our studio website. There may be some concepts in there that shed some light on this tricky business. http://www.doghouseNYC.com/articles/piano1.htm

Are you using Vista? Apparently Vista will commonly set USB audio devices to mono (on the assumption that it is a mono microphone I suppose). There is a setting in the Windows Control Panel to change the default recording setting for the USB device from mono to stereo. I’m using Linux, so I’m not able to give more precise details at the moment, but hopefully you will be able to find it.

Thanks, DogHouse. I like the idea of cutting some of the low frequencies. My mixer has a high-pass filter. Would that work?

Yep. But it may require more sculpting. Keyboard piano sounds are designed to sound good in the showroom. I find they rarely sit in a mix without some adjustment.

Steve – that was the trick!!!

Listen to this new sample – panned out and stereo (finally):
Old sample (mono and dull):http://www.snapdrive.net/files/372235/sample%20solo%20piano.mp3
New sample (stereo and panned)http://www.snapdrive.net/files/372235/sample%20piano-panned%20out-stereo.mp3

P.S… I didn’t even use any extra EQ. However, there’s a bit of hum. But the overall sound is much better!

Thanks again guys, for sticking with me on this!

You’re welcome.
If you have the time, perhaps you could post a note describing where you found the setting - could be useful for other users.

FOR RECORDING KEYBOARDS FROM A MIXER using USB INTO YOUR LAPTOP: (if using Windows Vista)
In Windows Vista, go to Control Panel.
Under “Sound” go to “Manage Audio Devices”
Click the USB device/mixer you’re using (it won’t show up unless it’s plugged in to your latop)
click the “Recording” tab.
Click your USB device/mixer again.
Click the “Advanced” tab.
Under that tab, there’s a pull-down menu. Choose the “2-channel, 16 bit, 48,000Hz-DVD quality” option.